Migration 38

Anyone managed to get migration 38 working yet (on PostGres)? From trunk
921.Here’s my rake trace.
** Invoke migrate (first_time)** Invoke environment (first_time)**
Execute environmentrake aborted!superclass must be a Class (Module
given)/var/www/html/channel200/app/models/configuration.rb:1/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:207:inload'/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:207:inload’/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:39:inrequire_or_load'/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:22:independ_on’/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:178:inrequire_dependency'/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:178:inrequire_dependency’/var/www/html/channel200/config/environment.rb:96/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
require__'/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire’/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:inrequire'/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/tasks/misc.rake:9/usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/tasks/misc.rake:8:incall’/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:232:in
execute'/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:232:ineach’/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:232:in
execute'/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:202:ininvoke’/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:195:in
synchronize'/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:195:ininvoke’/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:209:ininvoke_prerequisites'/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:208:ineach’/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:844:in
send'/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:844:ineach’/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:208:ininvoke_prerequisites'/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:201:ininvoke’/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:195:in
synchronize'/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:195:ininvoke’/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:1719:in
run'/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:1719:ineach’/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:1719:in
run'/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/bin/rake:7/usr/local/bin/rake:18:inload’/usr/local/bin/rake:18
david richardsontypo migrations â?? so much pain.

How can I run migration 38 manually? I have problems since I update to
revision 915…

typo just says “typo_development.blogs” doesn’t exist…

Thanks

Le Samedi 18 Mars 2006 05:46, David R. a écrit :

Ok, revision 922 fixes this. You can now upgrade via the admin
interface again.

For future reference, you can upgrade from the command-line by
running rake migrate RAILS_ENV=production from the root folder of
your typo installation (this upgrades the production database, use
RAILS_ENV=development to upgrade development if you have it).

didn’t work at all here.
d.r.

the upgrade kinda worked, I now have the blog table, but get this error
Processing GeneralController#index (for 69.140.109.194 at
2006-03-1809:23:53) [GET] Parameters: {“action”=>“index”,
“controller”=>“admin/general”}

ActiveRecord::StatementInvalid (Mysql::Error: Table
‘typo.settings’doesn’t exist: SELECT * FROM settings ):
/usr/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/connection_adapters/abstract_adapter.rb:88:inlog' /usr/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/connection_adapters/mysql_adapter.rb:180:inexecute’
/usr/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/connection_adapters/mysql_adapter.rb:322:inselect' /usr/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/connection_adapters/mysql_adapter.rb:171:inselect_all’
/usr/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/base.rb:431:infind_by_sql' /usr/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/base.rb:395:infind’
/app/models/config_manager.rb:13:in reload' /app/controllers/application.rb:53:inreload_settings’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/filters.rb:354:incall_filte! rs' /usr/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/filters.rb:350:incall_filters’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/filters.rb:339:inbefore_action' /usr/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/filters.rb:331:inperform_action_without_benchmark’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/benchmarking.rb:69:inperform_action_without_rescue' /usr/lib/ruby/1.8/benchmark.rb:293:inmeasure’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/benchmarking.rb:69:inperform_action_without_rescue' /usr/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/rescue.rb:82:inperform_action’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/base.rb:369:inprocess_without_session_management_support' /usr/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/session_management.rb:116:inprocess’
/usr/lib/ru!
by/gems/1.8/gems/rails-1.0.0/lib/dispatcher.rb:38:in dispatch' /usr/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:141:inprocess_request’
/usr/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:53:inprocess!' /usr/lib/ruby/1.8/fcgi.rb:600:ineach_cgi’
/usr/lib/ruby/1.8/fcgi.rb:597:in each_cgi' /usr/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:52:inprocess!’
/usr/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:22:inprocess!' /public/dispatch.fcgi:24 On 3/18/06, Kevin B. <[email protected]> wrote:> Ok, revision 922 fixes this. You can now upgrade via the admin> interface again.>> For future reference, you can upgrade from the command-line by> runningrake
migrate RAILS_ENV=production` from the root folder of> your typo
installation (this upgrades the production database, use>
RAILS_ENV=development to upgrade development if you have it).>> On Mar
17, 2006, at 11:02 PM, cedric wrote:>> > How can I run migration 38
manually? I have problems since I update to> > revision 915…> >> >
typo just says “typo_development.blogs” doesn’t exist…>> --> Kevin
Ballard> [email protected]> http://kevin.sb.org>
http://www.tildesoft.com>>>>>
_______________________________________________> Typo-list mailing list>
[email protected]>
http://rubyforge.org/mailman/listinfo/typo-list>>>

–Cheers,Kevin K.http://blog.kubasik.net/

Migration still failing with v 924
d.r.

“Kevin K.” [email protected] writes:

the upgrade kinda worked, I now have the blog table, but get this error
Processing GeneralController#index (for 69.140.109.194 at
2006-03-1809:23:53) [GET] Parameters: {“action”=>“index”,
“controller”=>“admin/general”}

Have you restarted your fcgi processes? Looks like you’ve got old code
trying to work with the new schema.

Working now. Be careful that your update procedure removes
deprecatedfile, rather than just updating existing files.
d.r.–www.channel200.net

“David R.” [email protected] writes:

Migration still failing with v 924

Can I have another copy of the rake trace? Preferably with linebreaks
this time.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs