Migrate Ubuntu Rails App to Fedora?


#1

I developed a small RoR app on my Ubuntu laptop and I just tried to
migrate
it to my “production” box which is Fedora FC3. I moved the entire
rails
app. I received this error when I tried to get the first page:

[2005-11-17 15:36:00] INFO WEBrick::HTTPServer#start: pid=32546
port=3000
192.168.0.61 - - [17/Nov/2005:15:40:01 EST] “GET /freesql HTTP/1.1” 200
0

  • -> /freesql
    [2005-11-17 15:40:01] ERROR MissingSourceFile: no such file to load –
    irb
    /usr/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
    require__' /usr/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:214:in
    require' /usr/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/breakpoint.rb:18 /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:207:inload’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:39:in
    require_or_load' /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:22:independ_on’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:178:in
    require_dependency' /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:194:inconst_missing’
    /usr/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/dispatcher.rb:76:in
    reset_after_dispatch' /usr/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/dispatcher.rb:46:indispatch’
    /usr/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/webrick_server.rb:117:in
    handle_dispatch' /usr/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/webrick_server.rb:83:inservice’
    /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in service' /usr/lib/ruby/1.8/webrick/httpserver.rb:65:inrun’
    /usr/lib/ruby/1.8/webrick/server.rb:173:in start_thread' /usr/lib/ruby/1.8/webrick/server.rb:162:instart_thread’
    /usr/lib/ruby/1.8/webrick/server.rb:95:in start' /usr/lib/ruby/1.8/webrick/server.rb:92:instart’
    /usr/lib/ruby/1.8/webrick/server.rb:23:in start' /usr/lib/ruby/1.8/webrick/server.rb:82:instart’
    /usr/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/webrick_server.rb:69:in
    dispatch' /usr/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/commands/servers/webrick.rb:59 /usr/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:214:in
    require' /usr/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/commands/server.rb:28 /usr/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:214:in
    `require’
    script/server:3

I figured that it might be a version problem (in fact, ruby
script/server
failed with an error until I updated ruby and rails). If I do “gem
update
rails” it reports everything is up to date. However, if I do “gem
update
activesupport” I get:

gem update activesupport
Upgrading installed gems…
Attempting remote upgrade of activesupport
Attempting remote installation of ‘activesupport’
Successfully installed activesupport-1.2.3
/usr/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in require__': no such file to load -- rdoc/rdoc (LoadError) from /usr/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from /usr/lib/site_ruby/1.8/rubygems/doc_manager.rb:43:in
generate_rdoc' from /usr/lib/site_ruby/1.8/rubygems/gem_commands.rb:215:inexecute’
from /usr/lib/site_ruby/1.8/rubygems/gem_commands.rb:214:in
execute' from /usr/lib/site_ruby/1.8/rubygems/gem_commands.rb:153:inexecute’
from /usr/lib/site_ruby/1.8/rubygems/gem_commands.rb:781:in
execute' from /usr/lib/site_ruby/1.8/rubygems/gem_commands.rb:777:inexecute’
from /usr/lib/site_ruby/1.8/rubygems/command.rb:49:in invoke' from /usr/lib/site_ruby/1.8/rubygems/cmd_manager.rb:94:inprocess_args’
from /usr/lib/site_ruby/1.8/rubygems/cmd_manager.rb:67:in run' from /usr/lib/site_ruby/1.8/rubygems/gem_runner.rb:13:inrun’
from /usr/bin/gem:17

Is the problem that my production server is not properly patched, or is
the
problem an ubuntu vs fedora configuration? (or something else?)

Thanks,

Gary


#2

seems like you might be missing some packages. Make sure you have the
following installed:

ruby
ruby-devel
ruby-libs
irb
rdoc

eduard


#3

Thank you!!

it was either irb or rdoc.

----- Original Message -----
From: eduard
To: removed_email_address@domain.invalid
Sent: Thursday, November 17, 2005 10:27 PM
Subject: Re: [Rails] Migrate Ubuntu Rails App to Fedora?

seems like you might be missing some packages. Make sure you have the
following installed:

ruby
ruby-devel
ruby-libs
irb
rdoc

eduard