Menuengine install issues

=> Booting WEBrick…
C:/xxy/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/depend
encies.rb:123:in const_missing': uninitialized constant Engines (NameError) from C:/xxy/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_s upport/dependencies.rb:131:inconst_missing’
from ./script/…/config/…/config/environment.rb:54
from
C:/xxy/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' from C:/xxy/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_s upport/dependencies.rb:147:inrequire’
from
C:/xxy/ruby/lib/ruby/gems/1.8/gems/rails-1.1.4/lib/commands/servers
/webrick.rb:52
from
C:/xxy/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' from C:/xxy/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_s upport/dependencies.rb:147:inrequire’
from
C:/xxy/ruby/lib/ruby/gems/1.8/gems/rails-1.1.4/lib/commands/server.
rb:30
from
C:/xxy/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' from C:/xxy/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_s upport/dependencies.rb:147:inrequire’
from script/server:3

what the problem?
How can I solve this problems?

did you install the engines plugin?

  • james

James A. wrote:

did you install the engines plugin?

  • james

yes,I have installed the engines plugin.

hasen wrote:

James A. wrote:

did you install the engines plugin?

  • james

yes,I have installed the engines plugin.

Does your boot.rb have anything like this:

if File.directory?("#{RAILS_ROOT}/vendor/rails")
require “#{RAILS_ROOT}/vendor/rails/railties/lib/initializer”
else
require ‘rubygems’
require ‘initializer’
end

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs