Marshal version problem

I have a script that generates a serialized file of native data
structures (hash of hashes & arrays and such).

In a short spike script I wanted to load up a particular file, and got a
version error:
incompatible marshal file format (can’t be read) (TypeError)
format version 4.8 required; 47.85 given

Both scripts invoke the same ruby instance on my system (OS X)
#! /usr/local/bin/ruby

printing RUBY_VERSION at the top of both scripts yields 1.8.6 in both.

wassup widdat?

– gw

On Jul 26, 2008, at 13:51 PM, Greg W. wrote:

#! /usr/local/bin/ruby

printing RUBY_VERSION at the top of both scripts yields 1.8.6 in both.

wassup widdat?

You’re not loading a Marshal file, you’re loading a file that starts
with “/U”

Eric H. wrote:

On Jul 26, 2008, at 13:51 PM, Greg W. wrote:

#! /usr/local/bin/ruby

printing RUBY_VERSION at the top of both scripts yields 1.8.6 in both.

wassup widdat?

You’re not loading a Marshal file, you’re loading a file that starts
with “/U”

Bah. Duh, I was giving load() a file path instead of the file data.

Thx.

– gw

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs