Markaby + Litespeed LSAPI: "warning already initialized cons

I’m trying to get a basic markaby script to work via litespeeds lsapi,
but it
keeps throwing the following error:

/usr/local/lib/ruby/site_ruby/1.8/i686-linux/lsapi.so: warning: already
initialized constant ENV

it seems to be something related to requiring gems but i’ve had no luck
finding a solution

#the script
require “rubygems”
require “markaby”

mab = Markaby::Builder.new
mab.html {
head { title “Markaby Test” }
body {
p “Some Text”
}
}

output is as expected in irb, i have rails app’s running flawlessly and
erb is
working using lsapi as a script handler - can anyone shed any light?

tried with:
ruby 1.8.4
markaby 0.3 & 0.4
litespeed 2.2.2 Standard
lsapi 1.8 & 1.9

tia

Answer to this question is published at
http://www.litespeedtech.com/community/forum/showthread.php?p=2953#post2953

Best Regards,
George W.

Scott M. wrote:

I’m trying to get a basic markaby script to work via litespeeds lsapi,
but it
keeps throwing the following error:

/usr/local/lib/ruby/site_ruby/1.8/i686-linux/lsapi.so: warning: already
initialized constant ENV

it seems to be something related to requiring gems but i’ve had no luck
finding a solution

#the script
require “rubygems”
require “markaby”

mab = Markaby::Builder.new
mab.html {
head { title “Markaby Test” }
body {
p “Some Text”
}
}

output is as expected in irb, i have rails app’s running flawlessly and
erb is
working using lsapi as a script handler - can anyone shed any light?

tried with:
ruby 1.8.4
markaby 0.3 & 0.4
litespeed 2.2.2 Standard
lsapi 1.8 & 1.9

tia

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs