(mandriva 2009) problem with installation kdevelop/ruby/Qt


#1

hello,

I would like to use kdevelop with Qt and ruby with a mandriva 2009.

so I downloaded kdevelop from the mandriva packages, it runs fine.

then, I installed Qt, and ruby.ok.

then, I had to install the binding Qt-kdevelop, referring at these
pages:

in the last page, I have only to install the 2 last packages I think.

so I installed qt4-qtruby, I installed smoke (./configure,make, make
install) (ok) then I have this error, while trying to install
qt4-qtruby:


[root@localhost qt4-qtruby-2.0.3]# cmake
-DCMAKE_INSTALL_PREFIX=/opt/kde4/ . && make && make install
– Found Qt-Version 4.5.0 (using /usr/bin/qmake)
– Ruby found: /usr/lib/libruby.so
– Build Smoke… yes - Qt, QtWebKit, QtScript, QtUiTools, QtTest
– Ruby found: /usr/lib/libruby.so
– Build QtRuby… yes
– Build QtWebKit Ruby… yes
– Build QtUiTools Ruby… yes
– Build QtScript… yes
– Build QtTest… yes
– Build QScintilla Ruby… no
– Build Qwt Ruby… no
CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.6)

should be added at the top of the file. The version specified may be
lower
if you wish to support older CMake versions for this project. For more
information run “cmake --help-policy CMP0000”.
This warning is for project developers. Use -Wno-dev to suppress it.

– Configuring done
CMake Warning (dev) at smoke/qtwebkit/CMakeLists.txt:28 (add_library):
Policy CMP0003 should be set before this line. Add code such as

if(COMMAND cmake_policy)
cmake_policy(SET CMP0003 NEW)
endif(COMMAND cmake_policy)

as early as possible but after the most recent call to
cmake_minimum_required or cmake_policy(VERSION). This warning appears
because target “smokeqtwebkit” links to some libraries for which the
linker
must search:

-lpthread

and other libraries with known full path:

/home/lolveley/bin/qt4-qtruby-2.0.3/smoke/qt/libsmokeqt.so.2.0.0

CMake is adding directories in the second list to the linker search path
in
case they are needed to find libraries from the first list (for
backwards
compatibility with CMake 2.4). Set policy CMP0003 to OLD or NEW to
enable
or disable this behavior explicitly. Run “cmake --help-policy CMP0003”
for
more information.
This warning is for project developers. Use -Wno-dev to suppress it.

– Generating done
– Build files have been written to: /home/lolveley/bin/qt4-qtruby-2.0.3
[ 35%] Built target smokeqt
[ 40%] Built target smokeqtwebkit
[ 45%] Built target smokeqtscript
[ 50%] Built target smokeqtuitools
[ 54%] Built target smokeqttest
[ 59%] Built target qtruby4shared
[ 61%] Built target qtruby4
[ 83%] Built target rbuic4_bin
[ 87%] Built target rbrcc
[ 90%] Built target rubyqtwebkit
[ 93%] Built target rubyqtuitools
[ 96%] Built target qtscript
Linking CXX shared module qttest.so
/usr/bin/ld: cannot find -lsmokekde
collect2: ld a retourné 1 code d’état d’exécution
make[2]: *** [ruby/qttest/qttest.so] Erreur 1
make[1]: *** [ruby/qttest/CMakeFiles/qttest.dir/all] Erreur 2
make: *** [all] Erreur 2


can you help me?

olivier.


#2

On Tuesday 05 May 2009, Olivier L. wrote:

|- [www.bawet.org] (in french)
|- [techbase.kde.org]
|- [rubyforge.org] finally.
|
|in the last page, I have only to install the 2 last packages I think.
|
|so I installed qt4-qtruby, I installed smoke (./configure,make, make
|install) (ok) then I have this error, while trying to install
|qt4-qtruby:

You don’t need to install smoke by itself, if you need to install qtruby
for
Qt4, it is included in the qt4 source tarball. Also, if you installed
smoke
using ./configure, make, make install, you installed the qt3 version of
smoke,
while the version of qtruby you want to install is for qt4.

So: what version of Qt do you wish to use? If you want to use qt4,
you’ll
simply need the qt4-qtruby-2.0.3.tgz file from
http://rubyforge.org/frs/?group_id=181&release_id=32620 then do the
following:

tar -xf qt4-qtruby-2.0.3.tgz
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/opt/kde4 …/qt4-qtruby-2.0.3
make
sudo make install

This should work. As I said, you don’t need to install smoke separately.
Since
you seem to have done that, I suggest that you uninstall it, before
doing the
above.

I hope this helps

Stefano


#3

hello,

thx for having answered to my question.
I want to use Qt4, eg without smoke if I have well understood you.

I will have to stop this installation due to problems with my graphic
card, but I will retry as soon as possible.

anyway, do you know the steps after having qt4-qtruby installed to have
kdevelop working with ruby and qt (notably having qtdesigner work in
kdevelop)?

olivier.


#4

On Tuesday 05 May 2009, Olivier L. wrote:

|hello,
|
|thx for having answered to my question.
|I want to use Qt4, eg without smoke if I have well understood you.

Not without smoke. What I meant is that you don’t need to install smoke
separately: the qt4-qtruby tarball already contains it.

|I will have to stop this installation due to problems with my graphic
|card, but I will retry as soon as possible.
|
|anyway, do you know the steps after having qt4-qtruby installed to have
|kdevelop working with ruby and qt (notably having qtdesigner work in
|kdevelop)?
|
|olivier.

Well, I don’t think you need to do anything special to have kdevelop
work with
ruby. If it was compiled with ruby support enabled, you should see some
ruby
projects templates when you choose the Project/new menu entry. If you
don’t
see it, chances are that you need to compile it by hand enabling ruby
support.
The qt designer should work with kdevelop without any special
configuration,
unless you want to use kdevelop 3 with Qt4. In that case, I’m afraid
you’ll
need to run the designer as a stand-alone program.

Stefano


#5

On May 5, 2:18 pm, Olivier L. removed_email_address@domain.invalid wrote:

  • [www.bawet.org] (in french)
    [root@localhost qt4-qtruby-2.0.3]# cmake
    – Build QScintilla Ruby… no
    This warning is for project developers. Use -Wno-dev to suppress it.
    cmake_minimum_required or cmake_policy(VERSION). This warning appears
    CMake is adding directories in the second list to the linker search path
    – Generating done
    [ 90%] Built target rubyqtwebkit

can you help me?
That’s a bug in the ruby/qttest/CMakeLists.txt file, you need to edit
it and remove the reference to ‘smokekde’. It has been fixed in the
KDE svn and so the fix will be in the next release of QtRuby.

– Richard