Make fails on nginx-0.8.49

Greetings

I am attempting to compile nginx-0.8.49 with the upstream fair module.
The configure script seems to run ok with the following options:

#./configure --add-module=../upfair

but when I run make it fails with this error:

objs/src/os/unix/ngx_process.o: In function `ngx_process_get_status':
/mnt/store/src/nginx/SOURCES/nginx-0.8.49/src/os/unix/ngx_process.c:490:
warning: `sys_errlist' is deprecated; use `strerror' or `strerror_r'
instead
/mnt/store/src/nginx/SOURCES/nginx-0.8.49/src/os/unix/ngx_process.c:490:
warning: `sys_nerr' is deprecated; use `strerror' or `strerror_r'
instead
make[1]: Leaving directory `/mnt/store/src/nginx/SOURCES/nginx-0.8.49'

And make install produces this:

[email protected]:/mnt/store/src/nginx/SOURCES/nginx-0.8.49]#make install
make -f objs/Makefile install
make[1]: Entering directory `/mnt/store/src/nginx/SOURCES/nginx-0.8.49'
test -d '/usr/local/nginx' || mkdir -p '/usr/local/nginx'
test -d '/usr/local/nginx/sbin'     || mkdir -p '/usr/local/nginx/sbin'
test ! -f '/usr/local/nginx/sbin/nginx'     || mv
'/usr/local/nginx/sbin/nginx'       '/usr/local/nginx/sbin/nginx.old'
cp objs/nginx '/usr/local/nginx/sbin/nginx'
test -d '/usr/local/nginx/conf'     || mkdir -p '/usr/local/nginx/conf'
cp conf/koi-win '/usr/local/nginx/conf'
cp conf/koi-utf '/usr/local/nginx/conf'
cp conf/win-utf '/usr/local/nginx/conf'
test -f '/usr/local/nginx/conf/mime.types'     || cp conf/mime.types
'/usr/local/nginx/conf'
cp conf/mime.types '/usr/local/nginx/conf/mime.types.default'
test -f '/usr/local/nginx/conf/fastcgi_params'     || cp
conf/fastcgi_params '/usr/local/nginx/conf'
cp conf/fastcgi_params 
'/usr/local/nginx/conf/fastcgi_params.default'
test -f '/usr/local/nginx/conf/fastcgi.conf'     || cp conf/fastcgi.conf
'/usr/local/nginx/conf'
cp conf/fastcgi.conf '/usr/local/nginx/conf/fastcgi.conf.default'
test -f '/usr/local/nginx/conf/uwsgi_params'     || cp conf/uwsgi_params
'/usr/local/nginx/conf'
cp conf/uwsgi_params     '/usr/local/nginx/conf/uwsgi_params.default'
test -f '/usr/local/nginx/conf/scgi_params'     || cp conf/scgi_params
'/usr/local/nginx/conf'
cp conf/scgi_params     '/usr/local/nginx/conf/scgi_params.default'
test -f '/usr/local/nginx/conf/nginx.conf'     || cp conf/nginx.conf
'/usr/local/nginx/conf/nginx.conf'
cp conf/nginx.conf '/usr/local/nginx/conf/nginx.conf.default'
test -d '/usr/local/nginx/logs'     || mkdir -p '/usr/local/nginx/logs'
test -d '/usr/local/nginx/logs' ||     mkdir -p '/usr/local/nginx/logs'
test -d '/usr/local/nginx/html'     || cp -r html '/usr/local/nginx'
test -d '/usr/local/nginx/logs' ||     mkdir -p '/usr/local/nginx/logs'
make[1]: Leaving directory `/mnt/store/src/nginx/SOURCES/nginx-0.8.49'

And if I try to start nginx this is what I get:

[[email protected]:/home/bluethundr]#service nginx start
Starting nginx:

I am on CentOS 55 x86_64

[[email protected]:/home/bluethundr]#uname -a
Linux LCENT01 2.6.18-194.11.3.el5xen #1 SMP Mon Aug 30 17:42:28 EDT 2010
i686 i686 i386 GNU/Linux
[[email protected]:/home/bluethundr]#cat /etc/redhat-release
CentOS release 5.5 (Final)

Any help I could get to help me get this going would be greatly
appreciated! :slight_smile:

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,136369,136369#msg-136369

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs