Make error during svn build (192)

any pointers on this build error?

git svn clone ruby
–revision 22000:23142
cd ruby
gc clean

autoconf --verbose

./configure --prefix=/home/jayeola/ix -program-suffix=192


checking limits.h presence… yes
configure: WARNING: limits.h: present but cannot be compiled
configure: WARNING: limits.h: check for missing prerequisite
configure: WARNING: limits.h: see the Autoconf documentation
configure: WARNING: limits.h: section “Present But Cannot Be
configure: WARNING: limits.h: proceeding with the preprocessor’s result
configure: WARNING: limits.h: in the future, the compiler will take


version.h:42:23: error: revision.h: No such file or directory
checking for nroff… /usr/bin/nroff
config.h unchanged
ruby192 library version = 1.9.1
configure: creating ./config.status
config.status: creating Makefile

gcc -g -O2-O3 -g -Wall -Wno-unused-parameter -Wno-parentheses
-Wno-missing-field-initializers -Wpointer-arith -Wwrite-strings -I.
-I.ext/include/i686-linux -I./include -I. -DRUBY_EXPORT -o main.o -c
cc1: error: invalid option argument ‘-O2-O3’
make: *** [main.o] Error 1

John M.
07739 171 531

Timezone: GMT

john maclean wrote:

any pointers on this build error?

You could start by describing your build environment (at minimum OS name
and version)

gcc -g -O2-O3 -g …
cc1: error: invalid option argument �-O2-O3�

Looks like you have something in your environment which is adding
unwanted extra flags to the gcc command line. Try ‘printenv’ and look
for something which might be doing that.


At Mon, 6 Apr 2009 21:19:33 +0900,
john maclean wrote in [ruby-talk:333115]:

any pointers on this build error?

Sorry, fixed now.