MacRuby 0.5 : Library not loaded

Hi,

I’m using XCode 3.2.3 and MacRuby 0.5.
I have created a MacRuby project which works perfectly on my mac.
But when i try the .app on another mac where probably the dev tools are
not installed, i got this error :

dyld: Library not loaded:
/Library/Frameworks/MacRuby.framework/Versions/0.5/usr/lib/libmacruby?dylib
Referenced from: ~/MyProject.app/Contents/MacOS/MyProject
Reason: image not found
sh: line 1: 39437 Trace/BPT trap
~/MyProject.app/Contents/MacOS/MyProject > /…

Any idea?

Stef Jeubs wrote:

Hi,

I’m using XCode 3.2.3 and MacRuby 0.5.
I have created a MacRuby project which works perfectly on my mac.
But when i try the .app on another mac where probably the dev tools are
not installed, i got this error :

dyld: Library not loaded:
/Library/Frameworks/MacRuby.framework/Versions/0.5/usr/lib/libmacruby?dylib
Referenced from: ~/MyProject.app/Contents/MacOS/MyProject
Reason: image not found
sh: line 1: 39437 Trace/BPT trap
~/MyProject.app/Contents/MacOS/MyProject > /…

Any idea?

Have you tried creating a statically linked binary of your MacRuby
project, or installing MacRuby on your other computer?

It looks like you are missing MacRuby on your another computer.

Best,
Rob

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs