Mac OS X Build problem

Hi all,

I have been trying to install the latest stable release (v3.1) on
Intel-Mac with Mac OS X(10.4.11). I have tried to follow both Jon
Jacky and Michael D.'s build guide, I had different problems.
Anyways, the problems can be concluded as follows:

  1. Since GNURadio 3.1 requires numpy instead of old Numeric, hence I
    either have to use python 2.4 installed by macports or I have to make
    numpy work on python2.4 (I failed to do so, not sure why).
  2. I tried to use python 2.4 (import numpy no problem), this is the
    command I used to build:

setenv GR /opt/local
./configure --prefix=$GR --with-pythondir=$GR/lib/python2.4/site-
sudo make insall


  1. When I tried to use mac build-in python (2.3.5), with numpy
    installed the error message I got while running some python script:

Traceback (most recent call last):
File “”, line 23, in ?
from gnuradio import gr, usrp, eng_notation
File “/usr/local/lib/python2.3/site-packages/gnuradio/”,
line 27, in ?
from gnuradio import gru
File “/usr/local/lib/python2.3/site-packages/gnuradio/gru/”, line 37, in ?
exec “from gnuradio.gruimpl.%s import *” % (f,)
File “”, line 1, in ?
File “/usr/local/lib/python2.3/site-packages/gnuradio/gruimpl/”, line 57, in ?
import numpy
File “/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/numpy/”, line 50, in ?
import ma
File “/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/numpy/ma/”, line 14, in ?
import core
File “/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/numpy/ma/”, line 113, in ?
max_filler.update([(k,-numpy.inf) for k in [numpy.float32,
AttributeError: keys

I doubt this is the problem of numpy. I did notice that numpy
requires python2.4 or higher, I am not sure if there is a work around
or not. Any hint would be appreciated.

Am I missing something somewhere?

Thanks in advance.

Qi Chen

Qi - It looks like you’re mixing Python 2.3 and 2.4. That’s not wise,
since there have been significant differences between decimal releases
of Python. Also, it’s possible that Python 2.3 is too old. I think
Python 2.5 is recommended, but 2.4 works for the most part. I would
highly recommend you installing the ‘python24’ port and related ‘py-
YYY’ ports, and see if those work for you. If you have install
issues, email me off-list and I’ll help as time allows. - MLD

Here’s another data point. I am using OS X 10.4.10 on a PPC Mac with
Python 2.3.5, the one that
comes with OS X 10.4. I have built GNU Radio from trunk recently with
no problems.

In order to avoid difficulties I have heard about on this list and
elsewhere, I have not installed another

Because I am still using the old Python, I can’t use MacPorts for any
packages that have Python
dependencies (otherwise MacPorts will install the new Python).

In March 2007 I installed NumPy 1.0.1 from the source tarball at
I see the current version is 1.0.4, but 1.0.1 is still available from
sourceforge (linked from the scipy

In 2005 I installed wxPython from
available at I see it’s
still there.

These work for me.

Jon Jacky

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs