Mac MySQL issues

Hi all, I’m having a problem with accessing MySQL from RoR on Mac OS X
Leopard.

Specifically when I try to create a scaffold, I get an access denied
for user error, no matter what username and password I try to use.
I’ve tried leaving it blank, and I’ve tried using my Mac admin
password without any luck.

I installed MySQL using the Hivelogic guide, and I’ve been working
through the Agile Web D. with Rails book (following their
Depot store example) and now I am stuck!

Running MySQL from the terminal seems to work fine, it’s only through
RoR that I have a problem. In fact the ‘create.sql’ script to set up
the database runs without any errors, so I’m a bit confused as to
what’s gone wrong now.

Any help would be much appreciated!

Thanks,

Mark

If you haven’t set up your username and password for MySQL,
your username is: root
and your password is:

Yes. Don’t type anything in the password.

Here’s my example:

development:
adapter: mysql
database: my_app_name_development
username: root
password:
socket: /tmp/mysql.sock

Aha, thanks very much! That must have been the only combination I
hadn’t tried!

Thanks again,

Mark

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs