Mac help with rubygems

Hi,

I’m trying to expand my horizons by learning to do some dev work on an
iMac that I inherited from a co-worker.

My understanding of Mac OS is fairly described as infantile; I think of
Mac OS as a really pretty version of Linux.

Now to my point…

I’m having some trouble with the FireRuby gem. It appears to install,
but running it; well here is the output…

hst-27-241:~ $ gem update fireruby
Updating installed gems…
Need to update 1 gems from http://gems.rubyforge.org
.
complete
Attempting remote update of fireruby
Select which gem to install for your platform (powerpc-darwin7.9.0)

  1. fireruby 0.4.1 (i586-linux)
  2. fireruby 0.4.1 (mswin32)
  3. fireruby 0.4.0 (mswin32)
  4. fireruby 0.4.0 (i586-linux)
  5. Skip this gem
  6. Cancel installation

1
Successfully installed fireruby-0.4.1-i586-linux
Installing ri documentation for fireruby-0.4.1-i586-linux…
Installing RDoc documentation for fireruby-0.4.1-i586-linux…
Gems: [fireruby] updated
hst-27-241:~ $ irb
irb(main):001:0> require ‘rubygems’
=> true
irb(main):002:0> require ‘fireruby’
LoadError: no such file to load – fr_lib
from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
gem_original_require' from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:inrequire’
from
/opt/local/lib/ruby/gems/1.8/gems/fireruby-0.4.1-i586-linux/lib/fireruby.rb:21
from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
`gem_original_require’
from
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
require’
from (irb):2
irb(main):003:0>

thus I interpret this to mean fr_lib.so file not found

I’ve also installed Firebird 1.5.x for good measure.

and now I wallow in Maconfusion,

any help appreciated

regards,

On 5/3/07, Andy K. [email protected] wrote:

I’m having some trouble with the FireRuby gem. It appears to install,
but running it; well here is the output…

I am not at all familiar with the “fireruby” project, but I can say
that if you try to install a gem that was intended for the
“i586-linux” platform on your Mac OS X box, it’s just not going to
work.

Based on the output of “gem update” that you included, it looks like
there in fact isn’t a Mac-specific gem for fireruby. There may be
other options available to you for using that software on your Mac,
however; you’ll just need to ask the fireruby developer(s) what’s up.

Hope this helps,

Lyle

On May 4, 2007, at 3:36 AM, Andy K. wrote:

I’m having some trouble with the FireRuby gem. It appears to
2. fireruby 0.4.1 (mswin32)
irb(main):001:0> require ‘rubygems’
custom_require.rb:32:in `gem_original_require’

and now I wallow in Maconfusion,

any help appreciated

regards,

Maybe this page can help:

http://fireruby.rubyforge.org/

According to this it should support OS X. However I see you’re
running PPC not Intel Mac, that means an extension written in C will
have to be recompiled. Endian issues.

Andy K. wrote:

Hi,

I’m trying to expand my horizons by learning to do some dev work on an
iMac that I inherited from a co-worker.

My understanding of Mac OS is fairly described as infantile; I think of
Mac OS as a really pretty version of Linux.

Now to my point…

I’m having some trouble with the FireRuby gem. It appears to install,
but running it; well here is the output…

thus I interpret this to mean fr_lib.so file not found

I’ve also installed Firebird 1.5.x for good measure.

and now I wallow in Maconfusion,

any help appreciated

regards,

Hi, I just recently discovered the same problem, not sure if you’ve
figured it out by now (looks like your post was a while ago…).
I don’t know why rubygems did not find the darwin version because if I
go to rubyforge: http://rubyforge.org/frs/?group_id=596&release_id=3732
the darwin gem is right there, just install with
sudo gem install /path/to/fireruby_0.4.1_powerpc_darwin.gem
-amiel

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs