Mac Firefox renders localhost rails pages smaller then safari or other browser

Hi there,

I’m using mac with snow leopard and ruby on rails in different version.

Every html-page from the internet is dispalyed on safari or firefox (4)
in the same way/size.

But my problem is, that only the pages from my rails projects (with
mogrel) are rendered on firefox about 15% smaller than in my stylsheets
defined.

If I’m using Safari on Mac or Firefox and IE8 with windows,everything is
rendered like defined.

Have anybody an Idea why?

Thanks ahead for every suggestion.

Regs

Hermann

did you ever press option-minus or option+plus for change the sizes in
firefox? because firefox remembers this… just a guess

On 2 May 2011 19:15, Herman Müller [email protected] wrote:

Hi there,

I’m using mac with snow leopard and ruby on rails in different version.

Every html-page from the internet is dispalyed on safari or firefox (4)
in the same way/size.

But my problem is, that only the pages from my rails projects (with
mogrel) are rendered on firefox about 15% smaller than in my stylsheets
defined.

Whenever a page renders differently on different browsers the first
thing to do is to check the source for html validity. View the page
in the browser then view the source (View > Page Source or similar)
copy the complete html text and paste it into the w3c html validator.
It may not be the problem but is always worth doing first.

Colin

Hi Thomas,

unbelievable, that’s it!!!

Thank you very much!!

I musst be more than one year ago when I pressed cmd+.

Regs

Hermann

Thomas M. wrote in post #996272:

did you ever press option-minus or option+plus for change the sizes in
firefox? because firefox remembers this… just a guess

On May 3, 2011, at 12:40 PM, Colin L. wrote:

Strange, almost unbelievable in fact.

Colin

If they all had the same address – localhost:3000 – then that’s not
too surprising.

Walter

On 3 May 2011 17:33, Herman Müller [email protected] wrote:

Hi Thomas,

unbelievable, that’s it!!!

Thank you very much!!

I musst be more than one year ago when I pressed cmd+.

So that only affected your rails apps and not other websites?
Strange, almost unbelievable in fact.

Colin

On 3 May 2011 17:58, Walter D. [email protected] wrote:

I musst be more than one year ago when I pressed cmd+.

So that only affected your rails apps and not other websites?
Strange, almost unbelievable in fact.

Colin

If they all had the same address – localhost:3000 – then that’s not too
surprising.

Apologies, I had missed the fact that FF remembers the setting on a
site by site basis. In which case, with some embarrassment, I
unreservedly withdraw my disbelief.

Colin

if you need to reset it you can simply use cmd-0 to reset to default.

They are all together 0 - + right next to each other.

I’m on ff4 and it looks like they implemented = so there is no need to
shift for + and here it’s control ( 0, -, +/= ) to control the
browser’s text accessibility option.

~

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs