Lost connection to mysql after rc4-upgrade


#1

Hi,

after upgrading to rails 1.0 rc4 I’m no longer able to connect to mysql
5.0. I’m on windows and have already reinstalled ruby
(one-click-installer) and rails with its dependencies. I’ve thought that
my attempts to install the native mysql bindings one week ago had caused
the problems, but after uninstalling and reinstalling everything I’m
pretty sure, that the pure ruby bindings to mysql should work again. I
had no problems with rc3 at least. This is the stack trace:

Lost connection to MySQL server during query: SELECT COUNT(*) FROM
schemes

|RAILS_ROOT: ./script/…/config/…|

Application Trace http://localhost:3000/admin/my_tree# | Framework
Trace http://localhost:3000/admin/my_tree# | Full Trace
http://localhost:3000/admin/my_tree#

|e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/abstract_adapter.rb:67:in log' e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/mysql_adapter.rb:164:inexecute’
e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/mysql_adapter.rb:297:in
select' e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/mysql_adapter.rb:147:inselect_one’
e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/abstract/database_statements.rb:16:in
select_value' e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/base.rb:534:incount_by_sql’
e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/base.rb:527:in
`count’

Has anyone experienced something like that? I’m stuck on that issue…

regards
Jan P.

The full framework trace:

||e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/abstract_adapter.rb:67:in log' e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/mysql_adapter.rb:164:inexecute’
e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/mysql_adapter.rb:297:in
select' e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/mysql_adapter.rb:147:inselect_one’
e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/connection_adapters/abstract/database_statements.rb:16:in
select_value' e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/base.rb:534:incount_by_sql’
e:/programme/ruby/lib/ruby/gems/1.8/gems/activerecord-1.13.0/lib/active_record/base.rb:527:in
count' e:/programme/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/base.rb:841:insend’
e:/programme/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/base.rb:841:in
perform_action_without_filters' e:/programme/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/filters.rb:332:inperform_action_without_benchmark’
e:/programme/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/benchmarking.rb:69:in
perform_action_without_rescue' e:/programme/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/benchmarking.rb:69:inmeasure’
e:/programme/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/benchmarking.rb:69:in
perform_action_without_rescue' e:/programme/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/rescue.rb:82:inperform_action’
e:/programme/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/base.rb:365:in
send' e:/programme/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/base.rb:365:inprocess_without_session_management_support’
e:/programme/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.0/lib/action_controller/session_management.rb:116:in
process' e:/programme/ruby/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/dispatcher.rb:38:indispatch’
e:/programme/ruby/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/webrick_server.rb:117:in
handle_dispatch' e:/programme/ruby/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/webrick_server.rb:83:inservice’
e:/programme/ruby/lib/ruby/1.8/webrick/httpserver.rb:104:in service' e:/programme/ruby/lib/ruby/1.8/webrick/httpserver.rb:65:inrun’
e:/programme/ruby/lib/ruby/1.8/webrick/server.rb:155:in start_thread' e:/programme/ruby/lib/ruby/1.8/webrick/server.rb:144:instart’
e:/programme/ruby/lib/ruby/1.8/webrick/server.rb:144:in start_thread' e:/programme/ruby/lib/ruby/1.8/webrick/server.rb:94:instart’
e:/programme/ruby/lib/ruby/1.8/webrick/server.rb:89:in each' e:/programme/ruby/lib/ruby/1.8/webrick/server.rb:89:instart’
e:/programme/ruby/lib/ruby/1.8/webrick/server.rb:79:in start' e:/programme/ruby/lib/ruby/1.8/webrick/server.rb:79:instart’
e:/programme/ruby/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/webrick_server.rb:69:in
dispatch' e:/programme/ruby/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/commands/servers/webrick.rb:59 e:/programme/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire__’
e:/programme/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
require' e:/programme/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:214:inrequire’
e:/programme/ruby/lib/ruby/gems/1.8/gems/rails-0.14.3/lib/commands/server.rb:28
e:/programme/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
require__' e:/programme/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire’
e:/programme/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.3/lib/active_support/dependencies.rb:214:in
`require’
script/server:3|


#2

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Nov 8, 2005, at 7:03 AM, Jan P. wrote:

after upgrading to rails 1.0 rc4 I’m no longer able to connect to
mysql 5.0. I’m on windows and have already reinstalled ruby (one-
click-installer) and rails with its dependencies. I’ve thought that
my attempts to install the native mysql bindings one week ago had
caused the problems, but after uninstalling and reinstalling
everything I’m pretty sure, that the pure ruby bindings to mysql
should work again. I had no problems with rc3 at least. This is the
stack trace:

Please see
http://dev.rubyonrails.org/ticket/428
and
http://dev.rubyonrails.org/ticket/1697

jeremy
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (Darwin)

iD8DBQFDcP8FAQHALep9HFYRAu0LAJ4z0gfDt9v6X1nkxWXYdwhdbUsy3wCcCgnT
5hcQPUFFOpmfygKVVapL2Cw=
=I7o3
-----END PGP SIGNATURE-----