Long wait configtest

Hi all

after several modification (implemented ocsp stapling) the command

“service nginx configtest”

I wait the return of configtest for circa one minute

i don’t understand the problem, before the command run in on second or
less.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,258721,258721#msg-258721

Hello!

On Thu, May 07, 2015 at 10:17:14AM -0400, zilog80 wrote:

Hi all

after several modification (implemented ocsp stapling) the command

“service nginx configtest”

I wait the return of configtest for circa one minute

i don’t understand the problem, before the command run in on second or less.

Likely there is a problem with name resolution.


Maxim D.
http://nginx.org/

Hi thanks for the answer

infact I add in the main

“resolver 8.8.8.8 8.8.4.4;”

you means that in my config I have a names without dns resolution?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,258721,258723#msg-258723

Hello!

On Thu, May 07, 2015 at 10:58:11AM -0400, zilog80 wrote:

Hi thanks for the answer

infact I add in the main

“resolver 8.8.8.8 8.8.4.4;”

you means that in my config I have a names without dns resolution?

Hostnames of OCSP resolvers are resolved during configuration
testing if OCSP Stapling is configured (much like all other
hostnames in a configuration), and this is done using a system
resolver. If your system resolver is slow this will affect
configuration testing time.


Maxim D.
http://nginx.org/

On Friday 08 May 2015 12:01:47 zilog80 wrote:

can i bypass the resolver test in configtest?

No.

wbr, Valentin V. Bartenev

can i bypass the resolver test in configtest?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,258721,258753#msg-258753

Thank you Valentin!
Today I have re-test the command and I waited for 3 minutes before
command
finishes
I’m surprised I use google DNS but usually its very fast,i don’t know
where
is wrong.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,258721,259015#msg-259015

Hi all

i solve my problem.

All configuration was correct.

The problem was IPV6 configuration, disable it and DNS responce get
fast!

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,258721,259726#msg-259726

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs