Log access denied

Problem: Mongrel cannot start because access to log is denied. I just
switched to a new development laptop (Snow Leopard). I think I
installed everything I needed. I git clone the application I am
developing from the repository. Everything went fine. Now when I run
script/server, this is what I get:

=> Booting Mongrel
=> Rails 2.3.5 application starting on http://0.0.0.0:3000
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/
1.8/logger.rb:518:in `initialize’: Permission denied - /Users/chief/
Documents/my_app/log/acts_as_ferret.log (Errno::EACCES)

Please help. Thanks.

On Fri, Feb 12, 2010 at 1:46 PM, Vincent P [email protected] wrote:

Documents/my_app/log/acts_as_ferret.log (Errno::EACCES)

Please help. Thanks.

So, what are the owner/permissions on that file, and what user
are you trying to start the app as?


Hassan S. ------------------------ [email protected]
twitter: @hassan

Thanks Hassan for your prompt response. I am trying to start mongrel
when logged in as a regular user. The log file somehow is owned by
root. I suspect that is because I am having apache and passenger
running at the same time trying to serve the same app. I’ll try to
disable apache.

After I run chown on the log files to take over ownership of the log
files, it works now. THanks.

On Feb 12, 1:59 pm, Hassan S. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs