Loading ftools.rb automatically

I have Ruby 1.8.5 patch-level xyz and Ruby 1.8.5 with no patch-level
on two different machines. The newer version of Ruby that has the
patch info autoloads ftools.rb automatically where as the older
version of Ruby does not. My question : Is there a way for me to load
the ftools.rb automatically in the older version of Ruby? TIA.

Hi,

At Thu, 17 Jul 2008 04:35:13 +0900,
[email protected] wrote in [ruby-talk:308363]:

I have Ruby 1.8.5 patch-level xyz and Ruby 1.8.5 with no patch-level
on two different machines. The newer version of Ruby that has the
patch info autoloads ftools.rb automatically where as the older
version of Ruby does not. My question : Is there a way for me to load
the ftools.rb automatically in the older version of Ruby? TIA.

No such patch has been incorporated. And ftools.rb had been
obsolete.

It is not obsolete,
http://redmine.ruby-lang.org/repositories/changes/ruby-187/lib/ftools.rb

It is still in Ruby 1.8.7. Am I missing something here?

On Jul 17, 2008, at 13:35 PM, [email protected] wrote:

No such patch has been incorporated. And ftools.rb had been
obsolete.

It is not obsolete, http://redmine.ruby-lang.org/repositories/changes/ruby-187/lib/ftools.rb

It is still in Ruby 1.8.7. Am I missing something here?

It is removed in ruby 1.9. It cannot be removed in 1.8 as old
programs depend on it.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs