LoadError: OpenSSL::SSL requires the jruby-openssl gem

While running the set of tests for the padrino-framework I’m having an
issue
with:

  1. Error:
    test: with resolving urls should resolve gist url properly.
    (TestPluginGenerator):
    LoadError: OpenSSL::SSL requires the jruby-openssl gem

/home/cdempsey/.rvm/rubies/jruby-1.6.0/lib/ruby/site_ruby/shared/jruby/openssl/autoloads/ssl.rb:8:in
`(root)’

/home/cdempsey/.rvm/rubies/jruby-1.6.0/lib/ruby/site_ruby/shared/jruby/openssl/autoloads/ssl.rb:124:in
`use_ssl=’

I’ve verified that I’ve got jruby-openssl (0.7.3) in my list of gems and
in
irb I can run basically what ssl.rb is doing:

jruby-1.6.0 :001 > require ‘rubygems’
=> true
jruby-1.6.0 :002 > gem ‘jruby-openssl’
=> true
jruby-1.6.0 :003 > require ‘openssl.rb’
=> true

Am I missing something? I’ve spend a few hours poking around and trying
my
google-fu but haven’t had much luck.

Environment info in case it helps at all:

jruby 1.6.0 (ruby 1.8.7 patchlevel 330) (2011-03-15 f3b6154) (OpenJDK
Client
VM 1.6.0_20) [linux-i386-java]
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10 2.6.35-28-generic
Codename: maverick

Actually, I’ve made this exact error happen in two different scenarios
today (go me!). The first, while running the padrino-framework tests
and when trying to install jquery into Rails 3.

Still working on narrowing it down.

Anything ever come of this? We are seeing similar behavior since we
upgraded to JRuby 1.6 and was wondering if you made any headway with
this?

-John

John D. wrote in post #994416:

Anything ever come of this? We are seeing similar behavior since we
upgraded to JRuby 1.6 and was wondering if you made any headway with
this?

-John

We are facing similar issue while upgrading to Jruby 1.6 and Rails 3.x

Any headaway?

Prachi T. wrote in post #1023089:

John D. wrote in post #994416:

Anything ever come of this? We are seeing similar behavior since we
upgraded to JRuby 1.6 and was wondering if you made any headway with
this?

-John

We are facing similar issue while upgrading to Jruby 1.6 and Rails 3.x

Any headaway?

Not sure if this helps anyone because this is a very old post, I edited
the bundler executable to include the jruby-ssl gem before it looks at
the path. It works, but isn’t right. Bundler isn’t tested with JRuby -
when I was searching around I found this out. The Bundler test suite
uses some C-Library extensions.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs