Listen backlog for stream servers

Hi,

Listen backlog in Nginx defaults to NGX_LISTEN_BACKLOG=511 on Linux &
other platforms (excepting FreeBSD & MacOS), not to system somaxconn
(why does it differ for different OSes?).

It’s not a problem to increase it using «backlog» option of «listen»
directive for HTTP servers
(http://nginx.org/en/docs/http/ngx_http_core_module.html#listen),
but there is no such option for stream server
(http://nginx.org/en/docs/stream/ngx_stream_core_module.html#listen).

Is there any proper way to increase listen queue length for stream
server (without patching source code) or globally? Seems to be a subject
to fix.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs