Linalg library dependence question


#1

Dear all,

I am trying to install the linalg library, which requires LAPACK to be
installed.
I use it under Cygwin and downloaded the latest version of Lapack and
installed it. However, in the install process, an error is produced,
because
a header file f2c.h is not found. Yet, I installed libf2c. It has that
file
in it,
and I also tried to copy it to the /usr/local/linalg directory, yet it
is
still not
found. Can you tell me what option to use in the make process to
successfully
install that library?

Thank you very much,

Axel



console output:
checking for f2c.h …: no
A full LAPACK installation was not found.
*** extconf.rb failed ***
Could not create Makefile for some reason, probably lack of necessary
libraries
and/or headers. Check the mkmf.log for more details.You may may
configuration
options.
Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=.
–curdir
–ruby=/usr/local/bin/ruby
install.rb : 127 in ‘config’ : Configuration failed (Runtime error)
from install.rb : 78 : in ‘each’

from install.rb : 77 : in ‘each’
from install.rb : 74 : in ‘each’

from install.rb : 124: in ‘config’

from install.rb : 206 : in ‘auto’

from install.rb : 215 .