Lighttpd path error

Hello list,
I’ve been developing a rails app using webrick as my server. I’m trying
to change my server over to lighttpd as I am now attempting to deploy on
a host that uses lighttpd. I had an older version of lighttpd installed
and could never get it running correctly with my app. Preparing for
deployment I decided to get lighty working and after poking around a bit
I upgraded to lighttpd-1.4.11 as that seemed to be the solution. Now, I
can start up lighty but I get the following error:
##################################################################
Max-Benjamins-Computer:telewriting maxbenjamin$ script/server

=> Booting lighttpd (use ‘script/server webrick’ to force WEBrick)
=> Rails application started on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140:in
load': no such file to load -- lib/12hour_helper.rb (MissingSourceFile) from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140:inload’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:56:in
require_or_load' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:30:independ_on’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:85:in
`require_dependency’
from
/Users/maxbenjamin/Desktop/telewriting/public/…/config/environment.rb:54
from
/Users/maxbenjamin/Desktop/telewriting/public/dispatch.fcgi:21
##################################################################

pointing my browser at http://localhost:3000/ I get a 500 error.

Any help would be very appreciated. I’ve been at this for waaaaay to
long.
Thanks,
Max

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs