Libusb error with gnuradio v3.4.2git


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

What are you intending to do with this installation? Sounds a bit like
OpenBTS to me. If this is your aim, what does OpenBTS say? I never
tested the installation this way, just fired the stuff up, and usually
it worked :slight_smile:

Ralph.

From: [email protected]lid
[mailto:[email protected]lid] On Behalf Of
Robert L.
Sent: Thursday, November 07, 2013 10:49 AM
To: [email protected]
Subject: [Discuss-gnuradio] libusb error with gnuradio v3.4.2git

Hi, Can someone help me to solve the problem below?

I have usrp1 with RFX1800. When running usrp_fft.py I get error “failed
to set initial frequency” and see no spectrum. starting usrp_fft.py -R A
helps at the beginning, I can see the spectrum, but any attempt to
change the frequency freezes the spectrum or causes it to dissapear and
says “failed”. And as you can see there are some fusb, libusb errors.

My usrp was working fine untill I upgraded to ubuntu 12.04 and
reinstalled gnuradio.

robert-pc:~/gnuradio$ usrp_fft.py
fusb::_reap libusb_handle_events() -10

(python:26722): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child
that doesn’t believe we’re it’s parent.

usrp_benchmark_usb.py returns:

Testing 2MB/sec… usb_throughput = 2M
ntotal = 1000000
nright = 999994
runlength = 999994
delta = 6
OK
Testing 4MB/sec… fusb::_cancel_lutusb_throughput = 4M
ntotal = 2000000
nright = 1997869
runlength = 1997655
delta = 2345
OK
Testing 8MB/sec… fusb::_cancel_lutusb_throughput = 8M
ntotal = 4000000
nright = 3998087
runlength = 3998087
delta = 1913
OK
Testing 16MB/sec…
fusb::_cancel_lutfusb::_cancel_lutfusb::_cancel_lutusb_throughput = 16M
ntotal = 8000000
nright = 7999035
runlength = 7999035
delta = 965
OK
Testing 32MB/sec…
fusb::_cancel_lutfusb::_cancel_lutfusb::_cancel_lutusb_throughput = 32M
ntotal = 16000000
nright = 15999605
runlength = 15999605
delta = 395
OK
Max USB/USRP throughput = 32MB/sec

I installed dependecies with build gnuradio script, then I did manual
installation. I have Ubuntu 12.04 3.2.0-55-generic-pae i386 i686.

I configured gnuradio with the following command:
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/ ./configure -q
–prefix=/home/robert/gr342 --disable-gr-qtgui --with-fusb-tech=libusb1
–enable-usrp --enable-gr-usrp --enable-gnuradio-core --disable-usrp2
–disable-volk

my .bashrc is below, I have a symbolic link pointing .sys >
/home/robert/gr342

PREFIX=/home/robert/.sys
export PATH=$PATH:$PREFIX/bin:/opt/microblaze/bin
export LD_LOAD_LIBRARY=$PREFIX/lib
export LD_LIBRARY_PATH=$PREFIX/lib
export PYTHONPATH=$PREFIX/lib/python2.7/site-packages
export PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig

export PATH=/opt/local/bin:/opt/local/sbin/:$PATH
export MANPATH=/opt/local/share/man:$MANPATH


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

Well, I installed a similar setup several times with Kubuntu 12.04,
without problems. All the libusb stuff is in place? Anyway, my actual
installation is a bad example, two much stuff mixed up, so for example I
have no idea what libusb version GR 3.4.2 is using, 0 or 1.

Ralph.

From: Robert L. [mailto:[email protected]]
Sent: Thursday, November 07, 2013 11:16 AM
To: Ralph A. Schmid, dk5ras
Cc: [email protected]
Subject: Aw: RE: [Discuss-gnuradio] libusb error with gnuradio v3.4.2git

You are right, my intention is to use it with OpenBTS or rather with
OsmoBTS. BTS says something like “failed to tune RX …” and
transceiver is not working properly. I also installed gnuradio many
times and never had a problem with usrp_fft.py and I completly don’t
know what the problem could be this time. Looks like the usb transfer is
working, but every attempt to change the settings of rfx1800 or usrp
fails. The same board works fine on another computer.

Gesendet: Donnerstag, 07. November 2013 um 11:02 Uhr
Von: “Ralph A. Schmid, dk5ras” [email protected]
An: “‘Robert L.’” [email protected], [email protected]
Betreff: RE: [Discuss-gnuradio] libusb error with gnuradio v3.4.2git

What are you intending to do with this installation? Sounds a bit like
OpenBTS to me. If this is your aim, what does OpenBTS say? I never
tested the installation this way, just fired the stuff up, and usually
it worked :slight_smile:

Ralph.

From: [email protected]lid
[mailto:[email protected]lid] On Behalf Of
Robert L.
Sent: Thursday, November 07, 2013 10:49 AM
To: [email protected]
Subject: [Discuss-gnuradio] libusb error with gnuradio v3.4.2git

Hi, Can someone help me to solve the problem below?

I have usrp1 with RFX1800. When running usrp_fft.py I get error “failed
to set initial frequency” and see no spectrum. starting usrp_fft.py -R A
helps at the beginning, I can see the spectrum, but any attempt to
change the frequency freezes the spectrum or causes it to dissapear and
says “failed”. And as you can see there are some fusb, libusb errors.

My usrp was working fine untill I upgraded to ubuntu 12.04 and
reinstalled gnuradio.

robert-pc:~/gnuradio$ usrp_fft.py
fusb::_reap libusb_handle_events() -10

(python:26722): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child
that doesn’t believe we’re it’s parent.

usrp_benchmark_usb.py returns:

Testing 2MB/sec… usb_throughput = 2M
ntotal = 1000000
nright = 999994
runlength = 999994
delta = 6
OK
Testing 4MB/sec… fusb::_cancel_lutusb_throughput = 4M
ntotal = 2000000
nright = 1997869
runlength = 1997655
delta = 2345
OK
Testing 8MB/sec… fusb::_cancel_lutusb_throughput = 8M
ntotal = 4000000
nright = 3998087
runlength = 3998087
delta = 1913
OK
Testing 16MB/sec…
fusb::_cancel_lutfusb::_cancel_lutfusb::_cancel_lutusb_throughput = 16M
ntotal = 8000000
nright = 7999035
runlength = 7999035
delta = 965
OK
Testing 32MB/sec…
fusb::_cancel_lutfusb::_cancel_lutfusb::_cancel_lutusb_throughput = 32M
ntotal = 16000000
nright = 15999605
runlength = 15999605
delta = 395
OK
Max USB/USRP throughput = 32MB/sec

I installed dependecies with build gnuradio script, then I did manual
installation. I have Ubuntu 12.04 3.2.0-55-generic-pae i386 i686.

I configured gnuradio with the following command:
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/ ./configure -q
–prefix=/home/robert/gr342 --disable-gr-qtgui --with-fusb-tech=libusb1
–enable-usrp --enable-gr-usrp --enable-gnuradio-core --disable-usrp2
–disable-volk

my .bashrc is below, I have a symbolic link pointing .sys >
/home/robert/gr342

PREFIX=/home/robert/.sys
export PATH=$PATH:$PREFIX/bin:/opt/microblaze/bin
export LD_LOAD_LIBRARY=$PREFIX/lib
export LD_LIBRARY_PATH=$PREFIX/lib
export PYTHONPATH=$PREFIX/lib/python2.7/site-packages
export PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig

export PATH=/opt/local/bin:/opt/local/sbin/:$PATH
export MANPATH=/opt/local/share/man:$MANPATH

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs