Libtiff issues (newb)

Hi all,

I am a brand new user here so please accept my apologies if this has
already been covered.

I have searched extensively for the problem I’m having but cannot find a
solution. Also, I am very new to Ruby on Rails. I played around with RoR
back in 2008 but never fully got into it.

I have installed all the required and not-so-required things needed like
rvm, homebrew, xcode (I’m on an iMac Lion OSX).

I’m trying to follow the Rails Cast from Ryan B. called #332 Refinery
CMS Basics located
here: http://railscasts.com/episodes/332-refinery-cms-basics

The problem is this:

I installed “imagemagick” as it suggests in the video. However, I keep
running into an issue where the “libtiff” dependency won’t install on my
machine. So I ran “brew doctor” to diagnose and it tells me “You should
brew install the missing dependencies: brew install libtiff”.

So, I did “brew install” and it starts making and configuring the
libtiff
and make installing but after a few seconds it says “error: OpenGL/gl.h:
No
such file or directory” as well as “Error: Failed executing: make
install
(libtiff.rb:18)”

I know this isn’t specifically a Rails issue but since I’m trying to
play
around RefineryCMS fromt he railscasts video I just wonder if anyone
else
has had this same issue? If so, any ideas on how to fix the problem? I
know that this will effect other things as well so not sure what I’m
doing
wrong.

Any information would be very helpful. Also, keep in mind I’m no expert
at
the command line.

If you need more information please let me know and I’ll do my best. I
didn’t want to copy/paste everything just yet in case it was a simple
answer.

Thanks very much in advance.