Library Require

I want to use the library ‘rubyful_soup’
(http://www.crummy.com/software/RubyfulSoup/)

Using ‘gem install rubyful_soup’ command, I installed the library.
The library is installed at /var/lib/gems/1.8/gems/.
When I use the library with irb, I typed

require ‘rubyful_soup.rb’,

but got an error message that ruby could not find such a file
‘rubyful_soup.rb’.
So after googling, I found the solution. The solution was to insert the
statement

require ‘rubygems’

before the statement

require ‘rubyful_soup.rb’.

It works well with irb, but I get an error message when practically
using with a controller class in a rails application.

Please help =)

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs