Leopard upgrade causing problem with ruby install

I installed Ruby by hand using the hive logic page a couple months
ago. After i upgraded to leopard I keep getting NSlinkModule() errors.
First when i ran ruby script/server and even when i run irb. Has
anyone navigated themselves out of this or have come by a tutorial to
fix this. Your help is greatly appreciated. Thanks!

I am fairly new to rails so I hope this isn’t a dumb question!

i had some trouble at beginning of the year, when i was updating my
Leopard to rails 2. solved if by installing xcode 3.0 to get the newest
libs etc.
i’m not sure that will help you, but it’s worth a try
you can download it for free after registering (free) with Apple
Developer Connection (ADC)

Why not just go back to the Ruby Leopard provides. It’s what I use and
is the recommended version for Rails at the present time. Should be as
easy as removing, or reordering, the PATH environment variable.

At least give that a try and see if you problem goes away. I see no
reason to roll your own Ruby on Rails on Leopard. The provided stuff
seems to be working great for me.

And yes, do install Xcode. You’ll definitely need that for installing
and gems that have native components to them. You need make for those,
which is installed along with Xcode.

On Jan 18, 5:03 am, Thorsten M. <rails-mailing-l…@andreas-