Legacy db and hyphen on column name issue

Hi I have a table called active
and another one called authreg
I did a one to one relation but it turns out that one of this legacy
database
column name has an hyphen!!! “-” now im screw how can I tell rails
to use it? or make an alias of some sort like with table names.?

@active = Active.new(
:collection-owner => authreg.username,
:time => “1207840612”)

Thanks


A Spectre is haunting multinational capitalism–the spectre of free
information.
All the powers of ``globalism’’ have entered into an unholy alliance to
exorcize this spectre:
Microsoft and Disney, the World Trade Organization, the United States
Congress and the European Commission.
Eben Moglen from the FSF.
http://emoglen.law.columbia.edu/publications/dcm.html

Solidarity:
http://www.dailyradical.org
http://www.diarioradical.org
http://www.spboston.org

rek2 wrote:

Thanks

nevermind I used ‘coolection-owner’ =>
and that seems to do the trick!


A Spectre is haunting multinational capitalism–the spectre of free
information.
All the powers of ``globalism’’ have entered into an unholy alliance to
exorcize this spectre:
Microsoft and Disney, the World Trade Organization, the United States
Congress and the European Commission.
Eben Moglen from the FSF.
http://emoglen.law.columbia.edu/publications/dcm.html

Solidarity:
http://www.dailyradical.org
http://www.diarioradical.org
http://www.spboston.org

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs