Learn Ruby in which version?

Hi,
There are some free books that were recommended to learn ruby, but
these books are in Ruby 1.6 (Programming Ruby The Pragmatic
Programmer’s Guide) and another one in Ruby 1.8.
Is it fine to learn from these books based on older versions, when
right now Ruby 1.8.7 and Ruby 1.9.2 are recommended?
Thank you.

http://apress.com/book/view/9781590597668

includes ruby 1.9

http://apress.com/book/view/1430223634

includes Ruby 1.9

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs