Ldap authentication with ruby

Hi All,

I am a new to ruby on rails… i would like to authenticate ruby site
using LDAP … I followed the link
http://wiki.rubyonrails.org/rails/pages/HowtoAuthenticateViaLdap

but after mentioning require ‘activeldap’ in config file and start the
webrick server it gives the following error message…

/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/webrick.rb:11:
warning: already initialized constant OPTIONS
/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/servers/webrick.rb:11:
warning: already initialized constant OPTIONS
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:28:in
gem_original_require': no such file to load -- activeldap (MissingSourceFile) from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:28:inrequire’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:in
require' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:342:innew_constants_in’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:in
require' from ./script/../config/../config/environment.rb:14 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:28:ingem_original_require’
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:28:in
require' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/active_support/dependencies.rb:495:inrequire’
… 8 levels…
from
/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/server.rb:39
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:34:in
gem_original_require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:34:inrequire’
from script/server:3

please help me out with ur answers…

thanks
Ambika.P

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs