Launchy 0.2.1 Released

launchy version 0.2.1 has been released.

http://copiousfreetime.rubyforge.org/launchy/

Launchy is helper class for launching cross-platform applications in a
fire and
forget manner. There are application concepts (browser, email client,
etc)
that are common across all platforms, and they may be launched
differently on
each platform. Launchy is here to make a common approach to launching
external
application from within ruby programs.

{{ Changelog for Version 0.2.1 }}

=== Version 0.2.1 - 2007-08-18

On Aug 18, 12:12 pm, Jeremy H. [email protected]
wrote:

{{ Changelog for Version 0.2.1 }}

=== Version 0.2.1 - 2007-08-18

  • fix inability to find windows executables [Bug #13132]

http://copiousfreetime.rubyforge.org/launchy/

From within your ruby code you can trust launchy to do the right
thing:

  Launchy.do_magic("http://www.ruby-lang.org/")

When you ultimately add new applications types, how will you be sure
Launchy does the right thing? What if I did:

  Launchy.do_magic("~/index.rhtml")

For me “do_magic” seems a little too magic, and as I mentioned before,
Launchy::Spawnable::Browser a little too long. I understand wanting to
have a “default” action, though I probably would have just named it
#open rather then #do_magic, but what do you think of also having
direct shortcuts like:

Launchy.browse(…)

Thanks,
T.

On Sun, Aug 19, 2007 at 05:30:43AM +0900, Trans wrote:

application from within ruby programs.
From within your ruby code you can trust launchy to do the right
For me “do_magic” seems a little too magic,
Yes, probably in hindsight a bad name. Naming things appropriately is
one
of the harder things to. I did this one in a fit of joy. I’m
probably going to change it.

and as I mentioned before, Launchy::Spawnable::Browser a little too
long.

I thought about this during this last update and I think I agree with
you now, so I’ll be making a change here. Such a long name for such
a little class…

I understand wanting to have a “default” action, though I
probably would have just named it #open rather then #do_magic, but
what do you think of also having direct shortcuts like:

Launchy.browse(…)

I was originally was thinking in that direction, and hadn’t decided if I
liked it or not. I’ll play with it a bit and see how I like it. The
will probably be another release of launchy later this week.

Thanks, T.

Thanks for the feedback.

enjoy,

-jeremy

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs