Laszlo on Rails kicking off


#1

The Laszlo on Rails effort, bringing the rich web interface of
OpenLaszlo (http://openlaszlo.org) to the simplicity of Rails
(http://www.rubyonrails.com) will be kicking off next week.

We have a list going at
http://groups.google.com/group/laszlo-on-rails/ – 88 people so far
and we haven’t even begun! – but if you really want to be close to
the action, email me with your firstname, lastname, username and
initial password and I will add you to our Basecamp project.

I want to emphasize that two of the design goals I have in mind are:

  1. Have as much of the controller code as possible in Ruby
  2. We want to enable selective use of Flash Laszlo widgets (including
    video and audio, of course) or entire UI’s in Flash via helpers.

So, if you want to include Flash elements in your Rails app without
having to code in ActionScript, you might want to check it out.

Happy New Year!

Mike P.


#2

Mike,

I’ve checked some demo’s on the formentioned url, and was smitten about
that
slick interface. I am a Rails newbie, but I would like to watch the
group
form the cormer of my eye to see what is up. If that’s ok, please let me
know.

Regards,

Gerard.

On Thursday 29 December 2005 22:22, Mike P. tried to type something
like:

I want to emphasize that two of the design goals I have in mind are:
Mike P.


Rails mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.org/mailman/listinfo/rails


“Who cares if it doesn’t do anything? It was made with our new
Triple-Iso-Bifurcated-Krypton-Gate-MOS process …”

My $Grtz =~ Gerard;
~
:wq!


#3

Hello,

I've got a CSV fixture where several lines have commas in the data.

When I try to load the fixture I get a CSV::IllegalFormatError. Deleting
the double quotes and comma fixes this, but then my data isn’t right.

This line doesn’t work,
69, “Cheeks, Palate and Tongue”, 3, 69

This line does
69, Cheeks Palate and Tongue, 3, 69

The “Agile” book and several on-line references indicate that the double
quotes should work. Any idea what’s wrong?

Thanks,
Steve


#4

Looks like the problem is that there is a space between the first
comma and the double quote. I had alot of trouble with this when I
was working on an app that used CSV. Try using

csvdata.gsub!(’, “’,’,”’)

That’s what I used!

-Jason


#5

Excellent, that worked. Is the space before the comma really invalid CSV
or is this a bug I should open a ticket for?

Thanks,
Steve


#6

Supposedly it is invalid CSV. At least, that’s what I’ve been told.

Glad it worked!

  • Jason

#7

Mike P. wrote:

I want to emphasize that two of the design goals I have in mind are:
Mike P.


Rails mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.org/mailman/listinfo/rails

I’d love to be added to the project. Mike H., Username mharris717,
Password cbase65


#8

What’s Mike P.'s email address? I didn’t receive that orig msg on
this.

-bakki