-l command line option broken?


#1

Ooops. I meant the -l option not -n.

It seems that ‘-l’ command line option for rspec stopped working as of
rspec 1.1.3. I think this may be related to why I can’t get NetBeans
to run focussed specs anymore. Does this work for others? I’m using
jruby but I don’t think that’s the issue.

http://ruby.netbeans.org/issues/show_bug.cgi?id=148462

-lenny


#2

On Tue, Oct 28, 2008 at 12:31 PM, Lenny M. removed_email_address@domain.invalid wrote:

Ooops. I meant the -l option not -n.

It seems that ‘-l’ command line option for rspec stopped working as of
rspec 1.1.3.

It’s been working for me. I wrote a Vim script that runs the current
spec
(in whatever window it might be) with DRb, so it takes about a second.
It’s
made a big difference in my TDD/BDD work cycle.

///ark


#3

On Tue, Oct 28, 2008 at 1:54 PM, Mark W. removed_email_address@domain.invalid wrote:

made a big difference in my TDD/BDD work cycle.

Come to think of it, I had to change the command it runs from
‘script/spec’
to ‘spec’ with the latest release of RSpec.

///ark


#4

On Tue, Oct 28, 2008 at 2:31 PM, Lenny M. removed_email_address@domain.invalid wrote:

Ooops. I meant the -l option not -n.

It seems that ‘-l’ command line option for rspec stopped working as of rspec
1.1.3. I think this may be related to why I can’t get NetBeans to run
focussed specs anymore. Does this work for others? I’m using jruby but I
don’t think that’s the issue.

http://ruby.netbeans.org/issues/show_bug.cgi?id=148462

I think 1.1.3 was the release that introduced nested example groups,
so it would make sense that the -l option fell apart. Please check
http://rspec.lighthouseapp.com and see if there is already a bug
report and add one if not.

Thx