Kryptcore load error in production, Rails 4.2


#1

I have updated to Rails 4.2.7.1 from Rails 4.1, and now get an error
when going into console mode, but only with production.

This works fine:
rails c

This worked fine in Rails 4.1, but now fails:
rails c production

Google has failed to find anything; can anyone here offer any help?

I am using JRuby, and have also upgraded that from 9.0.4 to 9.1.2, on
Windows 7, with PostgreSQL.

This is the stack trace:

LoadError: load error: kryptcore – java.lang.RuntimeException: null
require at org/jruby/RubyKernel.java:944
block in require at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274
load_dependency at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:240
require at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274
at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/krypt-core-0.0.2-universal-java/lib/krypt/core.rb:37
require at org/jruby/RubyKernel.java:944
block in (root) at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/bundler-1.12.5/lib/bundler/runtime.rb:1
each at org/jruby/RubyArray.java:1593
require at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/bundler-1.12.5/lib/bundler/runtime.rb:100
require at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/bundler-1.12.5/lib/bundler/runtime.rb:70
at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/bundler-1.12.5/lib/bundler.rb:102
require at org/jruby/RubyKernel.java:944
(root) at
R:/f2db3/config/application.rb:22
(root) at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:1
require_application_and_environment! at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:141
at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:67
require at org/jruby/RubyKernel.java:944
at
C:/jruby/jruby-9.1.2.0/lib/ruby/gems/shared/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:39


#2

The problem was this in my gemfile:

group :production do
gem ‘krypt-core’
gem ‘krypt-provider-jdk’
end

I had had to put it there for an earlier version; seems it is no longer
necessary.