[KNOWN BUG] Ruby/Tk cannot support latest Tcl/Tk8.6 (tailcall command)

$B1J0f!wCNG=!%6e9)Bg$G$9!%(B

$B<g$K(B 1.8.7 $B$H(B 1.9.2 $B$N%j%j!<%9%^%M%8%a%s%H$r$J$5$l$F$$$k(B
$BKNIt$5$s$H(B yugui $B$5$s$X$N>pJs$K$J$k$H;W$$$^$9!%(B

Tcl/Tk $B$N(B trunk (ActiveTcl-8.6.0.0b5 $B$b4^$`(B) $B$O(B
$B8=:_$N(B Ruby/Tk $B$G$O$^[email protected]%5%]!<%H$G$-$^$;$s!%(B

trunk $B$K$O!$?7$?$K(B tailcall $B$H$$$&%3%^%s%I$,<BAu$5$l$F(B
$B%i%$%V%i%j%9%/%j%W%H$NJ#?t2U=j$GMxMQ$5$l$F$$$k$N$G$9$,!$(B
$B$3$l$,8=:_$N(B tcltklib $B$N=hM}[email protected]$,0-$/$F!$(B
“tailcall cannot find the right splicing spot: should not happen!”
[email protected]$o$l$F(B Abort
$B$7$?$j!$7k2L$,[email protected]$i$l$kA0$K8F=P85$KLa$C$F$-$?$j$7$^$9!%(B
$B6qBNNc$H$7$F$O!$(BTk.getOpenFile $B$,$^$H$b$KF0$-$^$;$s!%(B

$BBP:v$r9M$($kI,MW$,$"$j$^$9$,!$$+$J$jLLE]$J$3$H$K$J$k$HM=A[$5$l$^$9$+$i!$(B
$BC;4|$G2r7h$9$k$3$H$O$G$-$J$$$H;W$$$^$9!%(B
$B$7$?$,$C$F!$EvLL$O(B known bug $B$H$$$&$3$H$K$5$;$F$/[email protected]$5$$!%(B

$B$h$m$7$/$*4j$$CW$7$^$9!%(B

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs