Json gem error help please?

Hi, Could someone please point me in the right direction, I need the
json gem for an apps I am working on, I’m new to RoR been working with
it for around 4 weeks now im instant rails on windows. i have been given
a requirements list for the gems. When I try to install the json gem
using “gem install json” I
am getting an error saying,

ERROR: Error installing json:
ERROR:Failed to build gem native extension.

C:/User…/…/./ruby/bin/ruby.exe extconf.rb install on
creating Makefile
nmake
‘nmake’ is not recognized as an internal or external command,
operable program or batch file.

gem file will remain installed in C:/User…/…/…/gems/json-1.1.2 for
inspection.
results logged to
c:/User/…/…/…/gems/json-1.1.2/ext/parser/gem_make.out

I have manually installed the gem to but this hasn’t seem to help
Sorry if this is very basic but like i say im new to ROR so all help is
greatly appreciated

Thanks Christopher

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Chris S. wrote:
| Hi, Could someone please point me in the right direction, I need the
| json gem for an apps I am working on, I’m new to RoR been working with
| it for around 4 weeks now im instant rails on windows. i have been given
| a requirements list for the gems. When I try to install the json gem
| using “gem install json” I
| am getting an error saying,

http://json.rubyforge.org/ if that’s the gem you are using.

In a nutshell:
c:\gem install json_pure

That installs a pure Ruby implementation of JSON.

The error you get is because you don’t a way to compile extensions (long
story short: You’ll need Visual C 6.0, but you can’t buy it easily).

| I have manually installed the gem to but this hasn’t seem to help

That’s because the install process is identical: The json gem will
always need to compile the extension. The only (feasible) solution would
be to get a Linux distribution installed, if you absolutely have to use
the C based gem.

| Sorry if this is very basic but like i say im new to ROR so all help is
| greatly appreciated

You’ve landed on the Ruby mailing list / forum, which is concerned
(mostly), with the Ruby part of Ruby on Rails.

(Ruby is the language used to make Rails possible.)

For Rails specific issues, look at one of these resources:
http://rubyonrails.org/community

  • – Phillip G.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkf2gWwACgkQbtAgaoJTgL8X0gCfdJCLlWUbTd2MGicVqlWtgnWk
3IgAn10HZoyveZeCYD3nMU21NIvWZxjw
=EymR
-----END PGP SIGNATURE-----

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs