Jruby -S rake gems:unpack:dependencies doesn't work


#1

I thought I’d try to “vendor everything” rather than letting warbler
unpack the gems at build time, but if I place these lines in my
environment.rb file:

config.gem ‘activerecord-jdbc-adapter’, :version => ‘0.9’
config.gem ‘activerecord-jdbcmysql-adapter’, :version => ‘0.9’
config.gem ‘jruby-openssl’, :version => ‘0.3’

I can’t even run the app with jruby script/server

Any suggestions? Is it possible to jar some of these gems with Rails
2.2.2 and then use them within a war? That would at least give me the
pre-packaging and version control of all dependencies that I’m looking
for.

Thanks,
Darcy.

This email communication and any files transmitted with it may contain
confidential and or proprietary information and is provided for the use
of the intended recipient only. Any review, retransmission or
dissemination of this information by anyone other than the intended
recipient is prohibited. If you receive this email in error, please
contact the sender and delete this communication and any copies
immediately. Thank you.
http://www.encana.com


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email