Jruby, qualcuno lo usa?

Come da oggetto.

Al momento non ne sento il bisogno :smiley:

Il giorno 21 gennaio 2012 15:00, Mauro [email protected] ha scritto:

On 21 January 2012 16:32, Luca B. [email protected] wrote:

Al momento non ne sento il bisogno :smiley:

era piu’ che altro per sapere se, dopo l’upgrade a rails 3.2, il
comando rake db:migrate vi da l’errore
“undefined method `accept’ for nil:NilClass”.
Cosa che immagino con ruby MRI non succeda.

Conosco gente che lo usa senza problemi, ma la mia esperienza
nell’usarlo
con Rails 3.1 su un’app molto basic non stato “liscia” per cos dire :slight_smile:

2012/1/21 Mauro [email protected]

http://lists.ruby-it.org/mailman/listinfo/ml


Andrea R.
Lelylan | reThink your house
http://lelylan.com

2012/1/24 Andrea R. [email protected]:

Conosco gente che lo usa senza problemi, ma la mia esperienza nell’usarlo
con Rails 3.1 su un’app molto basic non stato “liscia” per cos dire :slight_smile:

Che problemi hai avuto?
Praticamente non c’e’ nessuna differenza tra l’usare ruby o jruby se
non per la fase di deployment.

I got into this error http://jira.codehaus.org/browse/JRUBY-6164. Ho
provato diverse versioni di JRuby, ma niente da fare. Ho anche
tentato con Torquebox. Qui http://www.ruby-forum.com/topic/3037487 un
messaggio che avevo mandato in lista, e che per mia
colpa, non stato approfondito.

2012/1/24 Mauro [email protected]

http://lists.ruby-it.org/mailman/listinfo/ml


Andrea R.
Lelylan | reThink your house
http://lelylan.com

Lo usano in linkedin (
http://ontwik.com/ruby/how-linkedin-uses-jruby-on-its-front-end/ )

Paolo

2012/1/24 Andrea R. [email protected]

“undefined method `accept’ for nil:NilClass”.
Andrea R.
Lelylan | reThink your house
http://lelylan.com


Ml mailing list
[email protected]
http://lists.ruby-it.org/mailman/listinfo/ml


“… static analysis is fun, again!”

life from an application security guy ~> http://thesp0nge.com

2012/1/24 Andrea R. [email protected]:

I got into this error http://jira.codehaus.org/browse/JRUBY-6164. Ho
provato diverse versioni di JRuby, ma niente da fare. Ho anche
tentato con Torquebox. Qui http://www.ruby-forum.com/topic/3037487 un
messaggio che avevo mandato in lista, e che per mia
colpa, non stato approfondito.

Per quanto riguarda il primo bug hai provato le soluzioni che ti sono
state suggerite?
Usi thin?
Prova webrick, so che non e’ il massimo ma vedi se funziona, a me
funziona.
Io uso linux e openJDK, ho scaompattato il tar jruby, fatto jruby -S
gem install rails, dopodiche’ per ogni nuova app faccio:

jruby -S rails new myapp -m http://jruby.org/rails3.rb

rails s mi attiva webrick e tutto funziona perfettamente a parte un
bug con rails 3.2 ma se per il momento usi rails 3.1 non dovresti
avere problemi.

MRI ha sempre il GIL (Global Interpreter Lock) ma JRuby no. Gli unici
che non hanno il GIL sono JRuby e Rubinius. Quindi se la app girerasu un multicore, e meglio usare JRuby o Rubinius. Dr Nic dice proprio
questo: http://windycityrails.org/videos2011/#1

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs