Jruby-openssl 0.4 released!


#1

I just pushed jruby-openssl 0.4 to RubyForge.

Description:

JRuby-OpenSSL implements the “openssl” library for JRuby. It does not
require OpenSSL to exist on your system, and it only works with JRuby.

This version fixes the following bugs:

JRUBY-2992 Bad cast in jruby-openssl X509Utils
JRUBY-3288 jruby-openssl: SSLSocket.syswrite error for big (>16k) data
JRUBY-3163 Incorrect namespace for CipherError
JRUBY-3151 OpenSSL::Random#pseudo_bytes raises ArgumentError on negative
arguments
JRUBY-3416 Can’t rescue IOExceptions from jruby-openssl.
JRUBY-3335 OpenSSL: Provider BC not found
JRUBY-3249 Testing errors in test_java_mime.rb

Installation:

gem install jruby-openssl

  • Charlie