JRuby JDK Requirement?


#1

I’ve been all over the website, wiki, and faq trying to find the
supported JDK version for JRuby.
I’m assuming that JRuby requires JDK 1.5 or better due to the following
error…

$jruby --help
Exception in thread “main” java.lang.NoClassDefFoundError:
java/lang/Enum
at
org.jruby.RubyInstanceConfig.(RubyInstanceConfig.java:119)
at org.jruby.Main.(Main.java:77)
at org.jruby.Main.main(Main.java:81)


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#2

From what I recall, jruby 1.1 moved the minimum java version from 1.4.2
to 1.5/java5.

Ray K. wrote:


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#3

On 7 Nov, 2008, at 10:45 AM, Ray K. wrote:

I’ve been all over the website, wiki, and faq trying to find the
supported JDK version for JRuby.

The README file distributed with JRuby mentions this:

== Compiling from source

You will need:

  • JDK 1.5 or greater

I know you’re not trying to compile it, but if it compiles with 1.5
then it will run with 1.5.


Bill K.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#4

I’ve had a few apps in production running on JDK 1.5, and my dev box is
OSX
so only 1.5 :wink: so I can say for sure you can run it fine in 1.5.

On Fri, Nov 7, 2008 at 11:04 AM, David Christiansen


#5

I’ve had trouble with 1.5 and have to use 1.6 for my app.

On Fri, Nov 7, 2008 at 11:02 AM, Bill K. removed_email_address@domain.invalid wrote:


David Christiansen

removed_email_address@domain.invalid
www.techdarkside.com
317-966-6154 (mobile)


#6
  • JDK 1.5 or greater

I know you’re not trying to compile it, but if it compiles with 1.5 then it
will run with 1.5.


Bill K.

Aaah yes, the README, didn’t look in there. Thanks.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email