Jruby java options not working?


#1

Why doesn’t this work?

$ jruby -J-Xmx1024m -S warble war:clean

results in:

jruby: unknown option -J-Xmx1024m

I’m doing this because I keep getting this error when I run the command
without the java option:

Error: Your application used more memory than the safety cap.
Specify -J-Xmx####m to increase it (#### = cap size in MB).

Thanks!


David Christiansen

removed_email_address@domain.invalid
www.techdarkside.com
317-966-6154 (mobile)


#2

On Mar 11, 2009, at 9:16 AM, David Christiansen wrote:

Error: Your application used more memory than the safety cap.
Specify -J-Xmx####m to increase it (#### = cap size in MB).

Works just fine on jruby 1.1.6. What version are you running?

cr


#3

jruby 1.1.6RC1 (ruby 1.8.6 patchlevel 114) (2009-03-09 rev 6586)
[amd64-java]

On Wed, Mar 11, 2009 at 10:21 AM, Chuck R.
removed_email_address@domain.invalidwrote:


David Christiansen

removed_email_address@domain.invalid
www.techdarkside.com
317-966-6154 (mobile)


#4

Dave,

I ran the this command “jruby -J-Xmx1024m -S jirb” and it ran fine using
JRuby1.2.0-RC2. What version of JRuby are you using?

Josh

On Wed, Mar 11, 2009 at 10:16 PM, David Christiansen


#5

jruby 1.1.6RC1 (ruby 1.8.6 patchlevel 114) (2009-03-09 rev 6586)
[amd64-java]

On Wed, Mar 11, 2009 at 10:56 AM, Josh M. removed_email_address@domain.invalid
wrote:

317-966-6154 (mobile)


David Christiansen

removed_email_address@domain.invalid
www.techdarkside.com
317-966-6154 (mobile)


#6

We installed jruby 1.1.6 (ruby 1.8.6 patchlevel 114) (2009-03-11 rev
6586)
[amd64-java] and I still get the same error:

~ $ jruby -J-Xmx1024m -S jirb
jruby: unknown option -J-Xmx1024m

On Wed, Mar 11, 2009 at 10:57 AM, David Christiansen
removed_email_address@domain.invalidwrote:

Josh



David Christiansen

removed_email_address@domain.invalid
www.techdarkside.com
317-966-6154 (mobile)


David Christiansen

removed_email_address@domain.invalid
www.techdarkside.com
317-966-6154 (mobile)


#7

Is this JRuby installed from ports/yum/apt-get or something similar? Or
is it JRuby unpacked from our downloads? It almost looks like “jruby”
has been aliased to something else, or the -J processing has been broken
on your system.

David Christiansen wrote:

        results in:


David Christiansen

removed_email_address@domain.invalid mailto:removed_email_address@domain.invalid
www.techdarkside.com http://www.techdarkside.com
317-966-6154 (mobile)


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#8

On Mar 11, 2009, at 9:36 AM, David Christiansen wrote:

Specify -J-Xmx####m to increase it (#### = cap size in MB).

Works just fine on jruby 1.1.6. What version are you running?

Try the release version instead of the release candidate (RC1). This
may have been a bug that was fixed during the release candidate stage.

cr


#9

It was unpacked from your downloads. I think it has been aliased somehow

I’m looking into it. Thanks for the help.

On Wed, Mar 11, 2009 at 12:12 PM, Charles Oliver N. <
removed_email_address@domain.invalid> wrote:

~ $ jruby -J-Xmx1024m -S jirb
On Wed, Mar 11, 2009 at 10:56 AM, Josh M. <removed_email_address@domain.invalid
On Wed, Mar 11, 2009 at 10:16 PM, David Christiansen
I’m doing this because I keep getting this error when I run
www.techdarkside.com http://www.techdarkside.com
317-966-6154 (mobile)


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email


David Christiansen

removed_email_address@domain.invalid
www.techdarkside.com
317-966-6154 (mobile)