JRuby/glassfish v3 logging problem


#1

Hi all,

Ive just tried to run my app with jruby and glassfish. It seems to work
mostly fine, except one weird thing. Glassfish turns over
log/development.log when its size hits 1.9MB, renames it to something
like

development.log_2009-04-20T13-57-30

but never creates a fresh development.log and at that moment the
glassfish server just stops working.

What im doing is basically cd into my application’s RAILS_ROOT, and
execute glassfish_rails.

My OS is FreeBSD 7.2

Any ideas?


#2

I have the exact same problem. Has anyone figured out why this is?

Joe

On Apr 19, 11:01 pm, Petr J. removed_email_address@domain.invalid


#3

There are some known issues with logging, [1] and [2]. These issues are
being worked on and will be available in the next gem version (in couple
of
weeks). Apparently [1] is the cause of what you are experiencing related
to
rotation of log files.

Since rotation is not working so you as well disable it. Do the
following to
turn it off:

The setting for the log rotation is in domain.xml file. You can edit
$RAILS_ROOT/tmp/.glassfish/config/domain.xml.

Set log-roation-limit-in-bytes to 0 to disable the rotation.

-vivek.

[1]
http://rubyforge.org/tracker/index.php?func=detail&aid=24828&group_id=5450&atid=21080
[2]
http://rubyforge.org/tracker/index.php?func=detail&aid=25560&group_id=5450&atid=21080


#4

Permissions?

Blog: http://random8.zenunit.com/
Learn rails: http://sensei.zenunit.com/