JRuby 1.1.5 include_class breaks from myjar file...working in 1.1.4


#1

Something like this:
my_directory=’\build\WEB-INF\classes’
Dir.chdir(my_directory)
system(‘C:\jdk1.5.0\bin\jar cf myFile.jar .’)
require ‘myFile.jar’

Say Hello is now part of the myFile.jar

Now I do something like:
include_class ‘com.mypackage.Hello’

Worked in JRuby 1.1.4.

Fails in JRuby 1.1.5?

Something changed to include java class…or is this functionality
broken?
Had to go back to Jruby 1.1.4

View this message in context:
http://www.nabble.com/JRuby-1.1.5-include_class-breaks-from-myjar-file...working-in-1.1.4-tp20371243p20371243.html
Sent from the JRuby - User mailing list archive at Nabble.com.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#2

Anyone seen this?

This works without any issues in 1.1.4.
Was there an announcement on a workaround for this?

Please confirm.

Thanks!

drrs wrote:

include_class ‘com.mypackage.Hello’

Worked in JRuby 1.1.4.

Fails in JRuby 1.1.5?

Something changed to include java class…or is this functionality broken?
Had to go back to Jruby 1.1.4


View this message in context:
http://www.nabble.com/JRuby-1.1.5-include_class-breaks-from-myjar-file...working-in-1.1.4-tp20371243p20449505.html
Sent from the JRuby - User mailing list archive at Nabble.com.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#3

I see the same issue in Jruby 1.1.6 RC1…can anyone please clarify me
why
something like this:

my_directory=’\build\WEB-INF\classes’
Dir.chdir(my_directory)
system(‘C:\jdk1.5.0\bin\jar cf myFile.jar .’)
require ‘myFile.jar’

Say com.mypackage.Hello is now part of the myFile.jar

Now I do something like:
include_class ‘com.mypackage.Hello’

Worked in 1.1.4 and not in 1.1.5 and 1.1.6RC1?

Thanks in advance.


View this message in context:
http://www.nabble.com/JRuby-1.1.5-include_class-breaks-from-myjar-file...working-in-1.1.4-tp20371243p20984399.html
Sent from the JRuby - User mailing list archive at Nabble.com.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#4

drrs wrote:

Now I do something like:
include_class ‘com.mypackage.Hello’

Worked in 1.1.4 and not in 1.1.5 and 1.1.6RC1?

If there’s anything left that seems like a bug, please file one.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email