JRuby 1.1.2 jruby.bat's Xbootclasspath causes ClassNotFoundException


I have a Rails-application that serializes/unserializes some
Java-objects and stores them on the session between requests, using
ObjectOutputStream.writeObject() and ObjectInputStream.readObject().

The serialized Java-class is placed in a JAR-file specified on my
CLASSPATH environment-variable (in Windows XP).

Now, when I switched to JRuby 1.1.2, I suddenly started to get
ClassNotFoundExceptions, when I tried reloading the serialized objects.

(The objects are created without problems, so the classes are
definitively in my classpath)

This only happens when i run “Jruby script/server”, while it works fine
running in Tomcat (using jruby-complete.jar from jruby 1.1.2).

I ended up comparing the “jruby.bat” file for jruby 1.1.2 and jruby
1.1.1, and found out that if I replaced “-Xbootclasspath/a:”%CP%"
-classpath “%CLASSPATH%”" in the .BAT-file with : -cp “%CP%;%CLASSPATH%”

…it suddenly worked fine again…

I’m not familiar with the -Xbootclasspath parameter, so I wondered if
anyone here could tell me why this was changed in jruby 1.1.2, and
whether me changing my jruby.bat-file is possibly causing any other
problems ?

Alt i ett. FÃ¥ Yahoo! Mail med adressekartotek, kalender og notisblokk.