jEdit Ruby Editor Plugin 0.7.6 released


#1

The jEdit Ruby Editor Plugin release 0.7.6 is available for download at:

http://www.jedit.org/ruby/

This release gives you:

  • Introduce variable refactoring.
  • Copy, cut, paste actions that operate on whole line when no text is
    selected.
  • Smarter autocompletion of brackets and quotes; won’t add extra
    closing bracket/quote when you type closing char and there is already
    a closing char present.
  • Progressive selection now handling method selection better.

Other features include:

  • Syntax highlighting
  • Syntax error checking
  • Edit history navigation
  • Auto indent and insert end
  • Integrated RDoc viewer
  • Quote and bracket completion
  • Structure browser
  • Type-based code completion
  • Progressive selection
  • File structure navigation popup
  • Scope highlighting

Features from core jEdit or other plugins include:

  • Code folding
  • Code markers
  • Split panes
  • Autocompletion of HTML/XML elements via XML plugin
  • XPath expression evaluator via XSLT plugin
  • Visual diffs via JDiff plugin
  • Project managment via Project Viewer plugin

Feedback is welcome.

cheers,
Rob


#2

Great work Rob! Thanks for the update!

Matt


#3

Oh., It’s so cool!

Thank you :slight_smile:


#4

Joel VanderWerf wrote:

The following plugin cannot be loaded:
C:\Documents and Settings\vjoel.jedit\jars\RubyPlugin.jar:
Cannot load: java.util.zip.ZipException: error in opening zip file
The most likely reason is that the JAR file is corrupt; try
reinstalling it. See Utilities->Troubleshooting->Activity Log
for a full stack trace.

What did I do wrong?

I guess nothing (except I did it wrong as well).

The problem seems to be, that the server sends these jar-files with
content-type text/plain, which could cause Firefox (what do you use?) to
not treat it as binary files.

Downloading with InternetExplorer could work (its autodetection of
content-type identified the file as being .zip), but I never tested it.

Used wget to download and it works.

I downloaded it again with the same result.

The file also fails to open with java when I right click in Explorer and
select “open with… java”. Same error, essentially.

This is a completely clean install–I’ve never used jedit before.

It is not an issue with jedit but the server configuration. I guess.

Cheers


#5

Ouch, slow download, 0.3KB/sec! Are there any mirrors?

I decided to download this by ‘coralizing’ the URLs so these JARs should
become cached in the Coral CDN.

http://www.coralcdn.org/

So, hopefully if people want to download the necessary JARs it should be
fast after these JARs become fully cached.

These are the ‘coralized’ URLs for the JEdit RubyPlugin required JARs

http://jedit.org.nyud.net:8090/ruby/RubyPlugin.jar
http://jedit.org.nyud.net:8090/ruby/jruby.jar
http://jedit.org.nyud.net:8090/ruby/retroweaver.jar

  • Mark

#6

Rob . wrote:

The jEdit Ruby Editor Plugin release 0.7.6 is available for download at:

http://www.jedit.org/ruby/

I followed the instructions, but when I run jedit after installing the
plugins, I get an error message about RubyPlugin.jar:

The following plugin cannot be loaded:
C:\Documents and Settings\vjoel.jedit\jars\RubyPlugin.jar:
Cannot load: java.util.zip.ZipException: error in opening zip file
The most likely reason is that the JAR file is corrupt; try
reinstalling it. See Utilities->Troubleshooting->Activity Log
for a full stack trace.

What did I do wrong?

I downloaded it again with the same result.

The file also fails to open with java when I right click in Explorer and
select “open with… java”. Same error, essentially.

This is a completely clean install–I’ve never used jedit before.


#7

Mark E. wrote:

Ouch, slow download, 0.3KB/sec! Are there any mirrors?

Thanks for the feedback on the download problems. I’m taking steps to
have a more stable download setup.

Rob


#8

Stefan M. wrote:

I followed the instructions, but when I run jedit after installing the

Used wget to download and it works.
Thanks! I did use firefox. I’m using wget instead, and… that did it!