JDBC Oracle

Hi,

I’m trying to migrate the AR script on to Oracle database. Im using jdbc
adapter.

There are number of functions defined in jdbc_oracle.rb, but when I call
them (eg: rename_column(…)) in my AR script, it says “rake aborted !!
rename_column is not implemented” .
It is not referring to the jdbc_oracle.rb file. Is there any
configuration setting to be done?

I have written many custom functions in jdbc_postgre.rb and
jdbc_mssql.rb, it works absolutely fine.

Please find the sample code attached.

  1. 001_rename_columns.rb (file to migrate)

class CreateOrclTables < ActiveRecord::Migration
def self.up
rename_column(:companyprofile, :tname, :tname_new)
end
def self.down
end
end

  1. database.yml

development_orcl1:
adapter: jdbc
username: scott
password: tiger
driver: com.inet.ora.OraDriver
url: jdbc:inetora:vxind01:1521:BAPCDEV1

  1. jdbc_oracle.rb (adapter: jdbc)

The file is under (
D:\jruby-1.0.0RC1\lib\ruby\gems\1.8\gems\ActiveRecord-JDBC-0.3.1\lib\jdbc_adapter
)

Please refer the jdbc_oracle.rb file attached.

Appreciate your response !!

Thanks,
John

Attachments:
http://www.ruby-forum.com/attachment/1833/jdbc_oracle.rb


Posted via http://www.ruby-forum.com/.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

When I try to update or install the gems of Jruby 1.1.1 I get:
RemoteSourceException … NameError:unitialized constant
Gem::RemoteFetcher::StringIO reading http://gems.rubyforge.org/yaml .

How can I fix it?

Thanks,
Juan


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

This is a rubygems issue already reported to rubygems folks.
We’ve updated the JRuby to work around the problem for now.
So, JRuby 1.1.2 won’t have this problem.

The fix/workaround is very simple, in case if you would like to patch
your
JRuby installation yourself. Take a look here:
http://svn.jruby.codehaus.org/changelog/jruby/?cs=6598

Basically, you need to add require ‘stringio’ in one file.

thanks,
–Vladimir

On Fri, May 2, 2008 at 9:21 PM, Juan P.
[email protected] wrote:


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Hi John,

It seems that the AR-JDBC-Adapter you use now is very old. pls install
the latest version and try again.

 jruby -S gem install activerecord-jdbc-adapter

Cheers,
Jesse

2008/5/3 John E. [email protected]:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs