Javascripts

Trying to use auto_complete_for which works fine on my home system.

I see that when I use <%= javascript_include_tag “defaults” %>
that when used, the webrick reports
GET /javascripts/prototype.js
GET /javascripts/dragdrop.js
GET /javascripts/effects.js
GET /javascripts/controls.js

but on the system that I am trying to develop on and doing similarly,
the webrick only reports
GET /javascripts/defaults.js
even though public/javascripts/
has the other javascripts there in the folder.

I am thinking that this has something to do with why the
auto_complete_for function works on my home system but I have yet to
make it work on the system I am trying to develop for.

My home system is ruby-1.8.4-1.fc4 # Fedora-Core 4
my devel system is ruby-1.8.3-2.c2 # CentOS-4

Is this the issue? Why does use of
<%= javascript_include_tag "defaults %> seem to call the other
javascripts on my home system but not on the devel system?

Craig

Craig W. wrote:

Trying to use auto_complete_for which works fine on my home system.

I see that when I use <%= javascript_include_tag “defaults” %>
that when used, the webrick reports
GET /javascripts/prototype.js
GET /javascripts/dragdrop.js
GET /javascripts/effects.js
GET /javascripts/controls.js

The correct way to include the defaults is with

<%= javascript_include_tag :defaults %>

See
http://api.rubyonrails.com/classes/ActionView/Helpers/AssetTagHelper.html#M000394

Phil


Philip R.
http://tzinfo.rubyforge.org/ – DST-aware timezone library for Ruby

On Sat, 2006-01-28 at 20:22 +0000, Philip R. wrote:

The correct way to include the defaults is with

<%= javascript_include_tag :defaults %>

See
http://api.rubyonrails.com/classes/ActionView/Helpers/AssetTagHelper.html#M000394


bing!

thanks

Craig

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs