Java support - install a SecurityManager from JRuby

Not sure if I’m doing things 100% right.
I tried to extend a java class java.lang.SecurityManager and then
install it for the JVM (System.setSecurityManager) - I’ve expected for
this to work

but it didn’t - same result for 1.5.6 as well as 1.6.0.RC3 !

Is this a JRuby bug or is the java support not that mature or is it just
me doing something wrong :slight_smile: ?

Not really an answer, but I notice that it isn’t even managing to invoke
setSecurityManager.

What line of that script is it failing on - Is it the definition of that
JRubySecurityManager class, or when you invoke .new?

On Wed, 2011-03-09 at 12:03 +0100, Karol B. wrote:

me doing something wrong :slight_smile: ?


Nick G.
Developer @ Media Service Provider
+44 207 729 4797

right maybe it’s not clear at first :

the JRubySecurityManager.new is OK

what fails is the java.lang.System.setSecurityManager with the new
“jruby” manager.

if I understand correctly JRuby attempts to create a proxy for the first
checkPermission call (triggered by SecurityManager.checkExit) -
while doing so another security manager check is triggered (checkRead)
and it fails …

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs