Java 1.4.2 and JRuby 1.1 or 1.2


#1

Anyone working with JRuby 1.1 or 1.2 under Java 1.4.2 with
retro-translator?
If so, how’s it working? Care to pass along any hints before I give it a
go?

Thanks.
Dan


#2

Is there any published documentation as to which version of JRuby work
with
which versions of the JVM?
Can’t seem to find it.


#3

Dan,
I know it needs 1.5 or higher, but I don’t see where that is in the
docs/wiki. I’m not sure what sort of work you would need to get it to
run on 1.4 if that’s even possible.


#4

I’m mostly interested in rake support at the moment. I can get a 1.0.*
version of JRuby and rake combination working with 1.4.2.
Was hoping for some options to run a more recent version JRuby.


#5

Thanks Charles.
I’m going to work with 1.0.3 and 1.4.2 for a while and see how far that
gets
me. I was mostly concerned about bug fixes that I wouldn’t be able to
take
advantage of.
If it seems to be working out for me, and I need a newer version, I’ll
circle back around and put some effort into getting this working.
Sadly, I’m sorta used to doing this for various open source projects
since
I’m always stuck on old JVM’s…although JRuby is more unique than the
others I’ve done.

On Sat, Feb 28, 2009 at 4:16 PM, Charles Oliver N. <


#6

Dan Hatfield wrote:

I’m mostly interested in rake support at the moment. I can get a 1.0.*
version of JRuby and rake combination working with 1.4.2.
Was hoping for some options to run a more recent version JRuby.

We do not maintain JRuby for 1.4.2 because there’s been very little
interest in doing so. In the past, we have made “retroweaver” work for
JRuby, but it’s a stopgap measure at best. It doesn’t always translate
things correctly, and it’s tricky to keep from re-breaking code. Our
extensive use of Java 5 language features complicates matters further.

But it’s not impossible to make 1.4.2 support work. I have just done a
first spike of JRuby running on Java ME (CDC) which is actually a Java
1.3 environment. The process involved first stripping out libraries that
were not present on Java ME, and then getting retroweaver to produce a
Java 1.3-compatible jar. And it works!

The same process could apply to making a JRuby for Java 1.4.2, but would
require a lot less work. For example, I had to delete the IO subsystem,
but most of it could stay when running on 1.4.2.

So I’d say it’s not impossible, but we don’t have resources to really
make an effort right now. If you’re really interested, we’d love to
support you getting it running.

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#7

Ok, keep us posted. You’ll certainly lose a lot of fixes and
improvements compared to trunk, but depending on your use case it may
not be bad. And of course, if you see areas where trunk is right and
1.0.3 is wrong, it shouldn’t be too difficult to track down the change.

I personally would also have no problem handing over the 1.0 line to
external maintainers, but that’s for us all to decide.

Dan Hatfield wrote:

We do not maintain JRuby for 1.4.2 because there's been very little
retroweaver to produce a Java 1.3-compatible jar. And it works!

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

  http://xircles.codehaus.org/manage_email

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email