Jack Audio

Hi All,

I would like to try some experiments with gnuradio using the Jack Audio
Connection Kit as the input source. Following a note from 2009 that
Eric made, I put did the following:

Much easier to just edit ~/.gnuradio/config.conf
Add these three lines to the file:

verbose = True
audio_module = audio_jack

I tried the build that was made today with the ./build-gnuradio script,
and get the following message:

Could not find audio architecture “audio_jack” in registry.

 Defaulting to the first available architecture...

when running gnuradio-companion with a source and sink setup there.

In 2012, Anton had the same error message, so Tom suggested that he look
at what cmake was saying, and cmake is saying to me:

frohro@frohro-e6410:~/Projects/gnuradio/gnuradio/build$ cmake …/ |grep

– Found jack: /usr/lib/i386-linux-gnu/libjack.so

Tom also said to change the gr-auido.conf, and I did it.

You’ll also need to tell the config file to you jack, which you’ll
find in $prefix/etc/gnuradio/conf.d/gr-audio.conf and change ‘auto’ to

I still get the same message about defaulting to the first available

Does anyone have any insight that will help me out?



Rob F., PhD, PE
EF Cross School of Engineering
Walla Walla University
100 SW 4th Street
College Place, WA 99324
(509) 527-2075