Its' a general problem

After update of rack, will_paginate and rspec rake sys:

Missing the Rails 2.3.5 gem. Please gem install -v=2.3.5 rails,
update your RAILS_GEM_VERSION setting in config/environment.rb for the
Rails version you do have installed, or comment out RAILS_GEM_VERSION
to use the latest version installed.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

I have had the same bad experience.

Rack 1.1.0 does not work with Rails 2.3.5
Use Rack 1.0.1.

On Wed, Jan 20, 2010 at 11:18 AM, Mauro [email protected] wrote:

http://xircles.codehaus.org/manage_email


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

The problem is that rack-1.0.1 is no more in the repository.
How can I do?

2010/1/20 Maarten M. [email protected]:

Rails version you do have installed, or comment out RAILS_GEM_VERSION


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

It isn’t? I only installed it last week for a project,
jruby -S gem install rack -v=1.0.1

I think I got lucky then because I know for a fact that rack 1.1.0 is
backwards incompatible with Rails 2.3.5. I have no workaround, and had
the same fault, it did not recognize the gem for some reason.

Note that you also need jruby-rack 0.9.6 to work with Rails >= 2.3.3,
because of a problem that occurs in development mode (thread/mutex
lock problem).

On Wed, Jan 20, 2010 at 11:31 AM, Mauro [email protected] wrote:


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Ok, I found an old rack gem and I installed it.
My jruby-rack is 0.9.5, I use rails 2.3.5, until now I have no problems.
Why rack-1.1.0 is in the official repository if it has problems?

2010/1/20 Maarten M. [email protected]:


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

I don’t know, I was seriously pissed last week for it as well.
You’ll run into problems with jruby-rack 0.9.5 if you:

  • run rails in development mode
  • run rails in a java server (Tomcat, f.i.)

Typical symptom: first request goes fine, any other requests cause a
fatal threading error.

On Wed, Jan 20, 2010 at 11:47 AM, Mauro [email protected] wrote:

I think I got lucky then because I know for a fact that rack 1.1.0 is

The problem is that rack-1.0.1 is no more in the repository.

On Wed, Jan 20, 2010 at 11:18 AM, Mauro [email protected] wrote:

http://xircles.codehaus.org/manage_email

To unsubscribe from this list, please visit:


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

2010/1/20 Maarten M. [email protected]:

It isn’t? I only installed it last week for a project,
jruby -S gem install rack -v=1.0.1

Why do you use jruby -S and not jgem directly?


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

2010/1/20 Maarten M. [email protected]:

I don’t know, I was seriously pissed last week for it as well.
You’ll run into problems with jruby-rack 0.9.5 if you:

  • run rails in development mode
  • run rails in a java server (Tomcat, f.i.)

I’ve deployed a rails application in tomcat6.
I’ve created the war with warbler-0.9.14 that has jruby-rack 0.9.5 and
I have no problems, however I try to search for jruby-rack 0.9.6 and
put it into warbler.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

It’s the same, I never use jgem or jrake for some absurd reason.

On Wed, Jan 20, 2010 at 1:00 PM, Mauro [email protected] wrote:


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

On Wed, Jan 20, 2010 at 1:00 PM, Mauro [email protected] wrote:

Why do you use jruby -S and not jgem directly?

This is, actually, a good practice. That way you ensure that the
script is executed with exactly right JRuby (the one on the path).
Personally, I always do jruby -S for all jruby commands, except for
jirb. :slight_smile:

Thanks,
–Vladimir


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

On Wed, Jan 20, 2010 at 4:31 AM, Mauro [email protected] wrote:

The problem is that rack-1.0.1 is no more in the repository.
How can I do?

That seems very strange; old versions shouldn’t disappear. Have you
reported this to the Rack folks?

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

I have had the same bad experience.

Rack 1.1.0 does not work with Rails 2.3.5
Use Rack 1.0.1.

FYI: this ticket in Rails Lighthouse is describes the issue:

https://rails.lighthouseapp.com/projects/8994-ruby-on-rails/tickets/3685-actionpack-235-gem-declares-incompatibility-with-rack-110


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs