Issues on rails server -d (daemon server)

Hi, I’m trying to run ror server on background (i.e. the daemon server)

I ran the following cmd:

rails server -e production -d

In the beginning, everything is OK. I can go to the first page (index
However, when I try to query something (I build a small search engine),
it does not responding. The ruby is running, but the whole app does not

However, the interesting thing is when I try these cmd:

rails server
rails server -e production
nohup rails server -e production &

All thing went smoothly!

I tried to find out what is the problem, I have two link in the index
page that use a some controller (without a model). They response well.
When I tried query (with a model), it went dead, and never come back
again, here is the last log I can see:

Started GET
for .***.***. at 2012-06-11 23:03:26 -0400
Processing by RecommendationController#recommend as HTML
Parameters: {“utf8”=>“â”, “abstract”=>“pagerank”, “commit”=>“Get

Also I can not go back the index page again!

This is really a strange problem, can anyone help me solve this problem?

Thank you!